Bug 127039 - "Properties" fails with a Gtk error
"Properties" fails with a Gtk error
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-bind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-06-30 18:25 EDT by Moritz Barsnick
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: system-config-bind-4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 18:21:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2004-06-30 18:25:22 EDT
Description of problem:
When selecting "Properties" in system-config-bind(-gui), nothing 
happens in the GUI, and there are errors on the console.

Version-Release number of selected component (if applicable):
system-config-bind-2.0.2-8

How reproducible:
always

Steps to Reproduce:
1. run system-config-bind
2. press the "Properties" button
or
3. select File -> Properties
  
Actual results:
root@sunshine:/usr/local/Fedora_update/new > system-config-bind
Traceback (most recent call last):
  File "/usr/sbin/system-config-bind", line 436, in 
on_properties_activate
    on_bindconf_edit_button_clicked (None)
  File "/usr/sbin/system-config-bind", line 1374, in 
on_bindconf_edit_button_clicked
    zone = model.get_value (iter, COLUMN_DATA)
TypeError: iter must be a GtkTreeIter
Traceback (most recent call last):
  File "/usr/sbin/system-config-bind", line 1374, in 
on_bindconf_edit_button_clicked
    zone = model.get_value (iter, COLUMN_DATA)
TypeError: iter must be a GtkTreeIter

Expected results:
No errors, see a new window (?)

Additional info:
I haven't done _any_ bind config on this machine yet, and was hoping 
for help with a caching nameserver...
Comment 1 Moritz Barsnick 2004-11-03 14:30:16 EST
I'm the original bug poster. I currently can't reproduce in 2.0.2-10, 
but the traceback given in the original bug description might be of 
help to track a potential issue.

Note You need to log in before you can comment on or make changes to this bug.