Bug 1270430 - virt-install failed with install SLES 12 vm
Summary: virt-install failed with install SLES 12 vm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.2
Hardware: ppc64le
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1288337
TreeView+ depends on / blocked
 
Reported: 2015-10-10 03:15 UTC by Wayne Sun
Modified: 2016-11-04 01:58 UTC (History)
10 users (show)

Fixed In Version: virt-manager-1.3.2-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 01:58:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
virt-install debug log (6.31 KB, text/plain)
2015-10-13 02:24 UTC, Wayne Sun
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2269 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2016-11-03 13:34:19 UTC

Description Wayne Sun 2015-10-10 03:15:58 UTC
Description of problem:
virt-install failed with install with SLES 12, the hvm kernel path dir is not right for SLES 12.

Version-Release number of selected component (if applicable):
# rpm -q virt-install virt-manager-common
virt-install-1.2.1-8.el7.noarch
virt-manager-common-1.2.1-8.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. prepare a SLES 12 iso and install vm
# virt-install --name gsun_sles12_le -l /home/gsun/SLES-12-Server-DVD-ppc64le-GM-DVD1.iso --ram=2048 --vcpus=2 --hvm --debug --graphics vnc --wait -1 --prompt --accelerate --os-variant=virtio26 --network=network:default,model=spapr-vlan --serial pty --console pty --disk path=/home/gsun/sles12le_virtio.qcow2,size=8,bus='virtio' --extra-args "serial console=tty0 console=hvc0 netsetup=dhcp" --noreboot --os-variant sled12

it will fail at:
Retrieving file content...                                                                                                                                                                                            |  22 kB  00:00:00     
[Fri, 09 Oct 2015 23:07:48 virt-install 14681] DEBUG (urlfetcher:196) local hasFile: Couldn't find /var/lib/libvirt/boot/virtinstmnt.ROJaT9/boot/ppc64le/loader/linux
[Fri, 09 Oct 2015 23:07:48 virt-install 14681] DEBUG (urlfetcher:196) local hasFile: Couldn't find /var/lib/libvirt/boot/virtinstmnt.ROJaT9/boot/loader/linux

The right kernel path should be "/boot/linux" not "/boot/loader/linux"

2.
3.

Actual results:
fail

Expected results:
success

Additional info:

Comment 1 Wayne Sun 2015-10-10 03:19:58 UTC
correct the info of the right kernel path, it should be "boot/$arch_name/linux", just without 'loader' dir.

Comment 3 Pavel Hrdina 2015-10-12 11:11:02 UTC
Hi, could you please run those steps again with '--debug' parameter?

Thanks, Pavel.

Comment 4 Wayne Sun 2015-10-13 02:24:09 UTC
Created attachment 1082206 [details]
virt-install debug log

Comment 7 Pavel Hrdina 2015-11-02 16:41:44 UTC
Upstream commit:

commit 4578a4ec0f7c17d0a3b00a213f5e2dc07cb37f0b
Author: Pavel Hrdina <phrdina@redhat.com>
Date:   Mon Nov 2 13:43:59 2015 +0100

    virt-install: use correct path for linux and initrd for SLES on ppc64
    
    Install DVD of SLES for ppc64 has different path where linux and initrd
    are located.  Add those paths to kernel_paths to search also there, in
    case we are installing SLES on ppc64 host.
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1270430
    
    Signed-off-by: Pavel Hrdina <phrdina@redhat.com>

Comment 9 Mike McCune 2016-03-28 23:17:33 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 11 Xiaodai Wang 2016-07-19 11:17:58 UTC
I can reproduce it with virt-manager-1.2.1-8.el7.noarch:

Steps:
# virt-install --name testvm --memory 1024 --disk /var/lib/libvirt/images/testvm.img,size=5 -l /var/lib/libvirt/images/SLE-12-Server-DVD-ppc64le-GM-DVD1.iso 
WARNING  Graphics requested but DISPLAY is not set. Not running virt-viewer.
WARNING  No console to launch for the guest, defaulting to --wait -1

Starting install...
Retrieving file content...                                                                                                                                                                  |  22 kB  00:00:00     
ERROR    Couldn't find hvm kernel for SUSE tree.

then upgrade to latest , the installation can be started successfully.

So move the bug from ON_QA to VERIFIED.

Comment 13 errata-xmlrpc 2016-11-04 01:58:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2269.html


Note You need to log in before you can comment on or make changes to this bug.