Bug 1270440 - fedup ugprade from fedora 21 to 22 with RAID fails with wrong UUID
fedup ugprade from fedora 21 to 22 with RAID fails with wrong UUID
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-10 02:26 EDT by Turgut Kalfaoglu
Modified: 2015-10-12 14:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 14:02:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Turgut Kalfaoglu 2015-10-10 02:26:31 EDT
A simple system with two software raid 1 devices running fedora 21.

fedup --network 22 upgrade successfully finished.
However, the system would not reboot. It complained that /dev/md0 was not found.

Upon examining, the /boot/grub2.cfg file was found to contain the wrong UUID for the /dev/md0, the software RAID that was in place.

After booting from live USB, and learning the correct name from mdadm --examine --export , the grub file was updated manually and the system booted correctly.
Comment 1 Turgut Kalfaoglu 2015-10-10 02:27:25 EDT
correction:  mdadm --detail --export was the command.
Comment 2 Will Woods 2015-10-12 14:02:58 EDT
Yeah, this is one of the many problems that arises from trying to use a generic upgrade.img to boot everyone's systems - config files that get put into your initramfs are missing from upgrade.img, so the system doesn't always get set up correctly.

Since fedup is deprecated and has been replaced with dnf-plugin-system-upgrade in F21 and later, and dnf-plugin-system-upgrade doesn't use upgrade.img, this shouldn't be a problem anymore.

It sounds like you got your system upgraded already, but if anyone else hits this problem I'd suggest they use `dnf system-upgrade` instead.

Note You need to log in before you can comment on or make changes to this bug.