Bug 1270443 - Can not set -1 for data partition size
Summary: Can not set -1 for data partition size
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.1
: 3.6.1
Assignee: Ryan Barry
QA Contact: Ying Cui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-10 07:01 UTC by Ying Cui
Modified: 2016-03-09 14:40 UTC (History)
7 users (show)

Fixed In Version: ovirt-node-3.6.0-0.22.20151126git72acbb2.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:40:24 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
installer_data_size (7.77 KB, image/png)
2015-10-10 07:02 UTC, Ying Cui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 47302 master MERGED Allow -1 for data sizes again Never
oVirt gerrit 49260 ovirt-3.6 MERGED Allow -1 for data sizes again Never

Description Ying Cui 2015-10-10 07:01:59 UTC
Description of problem:
In TUI installer, here messages show for setting all free space by -1, but when set -1 on Data MB field, there -1 can not be accepted.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-201509280
ovirt-node-3.3.0-0.10.20150928gite7ee3f1.el7ev.noarch 

How reproducible:
100%

Steps to Reproduce:
1.TUI clean install RHEV-H7-7.2-20150928
2.One by one step to storage volume page  
3.Set -1 in Data MB field to fill all free space

Actual results:
-1 can not be accepted.

Expected results:
Can set -1 for data size to fill all free space.

Comment 1 Ying Cui 2015-10-10 07:02:28 UTC
Created attachment 1081527 [details]
installer_data_size

Comment 2 Ying Cui 2015-10-10 07:14:44 UTC
No useful log info for this action, so need to check attachment pic to clear the bug.

Comment 5 Ying Cui 2015-12-09 03:23:12 UTC
VERIFIED this bug on build rhev-hypervisor7-7.2-20151201.2(ovirt-node-3.6.0-0.23.20151201git5eed7af.el7ev.noarch)

Test steps:
1.TUI clean install rhevh 7.2-20151201.2
2.One by one step to storage volume page  
3.Set -1 in Data MB field to fill all free space
4. Installation finished
5. check lvs to ensure Data size. 

Result: Can set -1 for data size to fill all free space, and installation finished, data size is correct.

Comment 7 errata-xmlrpc 2016-03-09 14:40:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.