Bug 1270444 - [abrt] youtube-dl: ssl.py:621:read:SSLError: ('The read operation timed out',) [NEEDINFO]
Summary: [abrt] youtube-dl: ssl.py:621:read:SSLError: ('The read operation timed out',)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: youtube-dl
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Till Maas
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:cdcf8769dfe4198d3dcaab176a5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-10 07:10 UTC by Samy
Modified: 2018-04-11 12:28 UTC (History)
4 users (show)

Fixed In Version: youtube-dl-2016.02.13-1.fc23 youtube-dl-2016.02.13-1.fc22 youtube-dl-2016.02.13-1.el7 youtube-dl-2016.02.13-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-21 13:00:51 UTC
mcepl: needinfo? (melaine.samy)


Attachments (Terms of Use)
File: backtrace (2.44 KB, text/plain)
2015-10-10 07:10 UTC, Samy
no flags Details
File: environ (3.36 KB, text/plain)
2015-10-10 07:10 UTC, Samy
no flags Details

Description Samy 2015-10-10 07:10:03 UTC
Version-Release number of selected component:
youtube-dl-2015.09.09-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python2 /usr/bin/youtube-dl -t https://www.youtube.com/watch?v=fI6-02ATz4w
dso_list:       python-libs-2.7.10-8.fc22.x86_64
executable:     /usr/bin/youtube-dl
kernel:         4.1.10-200.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
ssl.py:621:read:SSLError: ('The read operation timed out',)

Traceback (most recent call last):
  File "/usr/bin/youtube-dl", line 9, in <module>
    load_entry_point('youtube-dl==2015.9.9', 'console_scripts', 'youtube-dl')()
  File "/usr/lib/python2.7/site-packages/youtube_dl/__init__.py", line 410, in main
    _real_main(argv)
  File "/usr/lib/python2.7/site-packages/youtube_dl/__init__.py", line 400, in _real_main
    retcode = ydl.download(all_urls)
  File "/usr/lib/python2.7/site-packages/youtube_dl/YoutubeDL.py", line 1658, in download
    url, force_generic_extractor=self.params.get('force_generic_extractor', False))
  File "/usr/lib/python2.7/site-packages/youtube_dl/YoutubeDL.py", line 660, in extract_info
    ie_result = ie.extract(url)
  File "/usr/lib/python2.7/site-packages/youtube_dl/extractor/common.py", line 287, in extract
    return self._real_extract(url)
  File "/usr/lib/python2.7/site-packages/youtube_dl/extractor/youtube.py", line 1057, in _real_extract
    errnote='unable to download video info webpage')
  File "/usr/lib/python2.7/site-packages/youtube_dl/extractor/common.py", line 438, in _download_webpage
    res = self._download_webpage_handle(url_or_request, video_id, note, errnote, fatal, encoding=encoding)
  File "/usr/lib/python2.7/site-packages/youtube_dl/extractor/common.py", line 349, in _download_webpage_handle
    content = self._webpage_read_content(urlh, url_or_request, video_id, note, errnote, fatal, encoding=encoding)
  File "/usr/lib/python2.7/site-packages/youtube_dl/extractor/common.py", line 371, in _webpage_read_content
    webpage_bytes = urlh.read()
  File "/usr/lib64/python2.7/socket.py", line 355, in read
    data = self._sock.recv(rbufsize)
  File "/usr/lib64/python2.7/httplib.py", line 588, in read
    return self._read_chunked(amt)
  File "/usr/lib64/python2.7/httplib.py", line 652, in _read_chunked
    value.append(self._safe_read(amt))
  File "/usr/lib64/python2.7/httplib.py", line 703, in _safe_read
    chunk = self.fp.read(min(amt, MAXAMOUNT))
  File "/usr/lib64/python2.7/socket.py", line 384, in read
    data = self._sock.recv(left)
  File "/usr/lib64/python2.7/ssl.py", line 734, in recv
    return self.read(buflen)
  File "/usr/lib64/python2.7/ssl.py", line 621, in read
    v = self._sslobj.read(len or 1024)
SSLError: ('The read operation timed out',)

Local variables in innermost frame:
buffer: None
x: SSLError('The read operation timed out',)
self: <ssl.SSLSocket object at 0x7fe2e3148320>
len: 418

Comment 1 Samy 2015-10-10 07:10:08 UTC
Created attachment 1081528 [details]
File: backtrace

Comment 2 Samy 2015-10-10 07:10:11 UTC
Created attachment 1081529 [details]
File: environ

Comment 3 Matěj Cepl 2016-02-15 08:20:35 UTC
Can you reproduce it with the latest release of youtube (you can get the latest testing from the URL which will be shown below)? I certainly cannot reproduce it here and it seems to me like a transient network issue.

Comment 4 Fedora Update System 2016-02-15 08:22:21 UTC
youtube-dl-2016.02.13-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7feb9ef02f

Comment 5 Fedora Update System 2016-02-15 08:22:59 UTC
youtube-dl-2016.02.13-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a8e4602ba0

Comment 6 Fedora Update System 2016-02-15 08:23:18 UTC
youtube-dl-2016.02.13-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-0ef5e7ce16

Comment 7 Fedora Update System 2016-02-15 08:24:35 UTC
youtube-dl-2016.02.13-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-da0453d87c

Comment 8 Fedora Update System 2016-02-17 04:48:42 UTC
youtube-dl-2016.02.13-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-da0453d87c

Comment 9 Fedora Update System 2016-02-17 04:49:58 UTC
youtube-dl-2016.02.13-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-0ef5e7ce16

Comment 10 Fedora Update System 2016-02-17 06:27:30 UTC
youtube-dl-2016.02.13-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7feb9ef02f

Comment 11 Fedora Update System 2016-02-17 06:29:40 UTC
youtube-dl-2016.02.13-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a8e4602ba0

Comment 12 Fedora Update System 2016-02-21 13:00:43 UTC
youtube-dl-2016.02.13-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-02-21 16:20:04 UTC
youtube-dl-2016.02.13-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-02-21 16:25:57 UTC
youtube-dl-2016.02.13-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2016-02-29 22:21:20 UTC
youtube-dl-2016.02.13-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2016-03-10 13:57:58 UTC
youtube-dl-2016.02.13-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2016-03-10 19:54:29 UTC
youtube-dl-2016.02.13-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.