Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1270514 - [abrt] ibus: bus_dbus_impl_dispatch_message_by_rule(): ibus-daemon killed by SIGABRT [NEEDINFO]
Summary: [abrt] ibus: bus_dbus_impl_dispatch_message_by_rule(): ibus-daemon killed by ...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus
Version: 23
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:75db545dfce1b8ef1c186df1d5b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-10 12:46 UTC by daniel.kermac
Modified: 2016-08-11 19:25 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-20 07:48:36 UTC
Type: ---
tfujiwar: needinfo? (daniel.kermac)


Attachments (Terms of Use)
File: backtrace (12.79 KB, text/plain)
2015-10-10 12:46 UTC, daniel.kermac
no flags Details
File: cgroup (190 bytes, text/plain)
2015-10-10 12:46 UTC, daniel.kermac
no flags Details
File: core_backtrace (9.01 KB, text/plain)
2015-10-10 12:46 UTC, daniel.kermac
no flags Details
File: dso_list (1.92 KB, text/plain)
2015-10-10 12:46 UTC, daniel.kermac
no flags Details
File: environ (1.68 KB, text/plain)
2015-10-10 12:46 UTC, daniel.kermac
no flags Details
File: limits (1.29 KB, text/plain)
2015-10-10 12:46 UTC, daniel.kermac
no flags Details
File: maps (10.30 KB, text/plain)
2015-10-10 12:46 UTC, daniel.kermac
no flags Details
File: mountinfo (3.36 KB, text/plain)
2015-10-10 12:46 UTC, daniel.kermac
no flags Details
File: namespaces (85 bytes, text/plain)
2015-10-10 12:46 UTC, daniel.kermac
no flags Details
File: open_fds (1.52 KB, text/plain)
2015-10-10 12:46 UTC, daniel.kermac
no flags Details
File: proc_pid_status (1015 bytes, text/plain)
2015-10-10 12:46 UTC, daniel.kermac
no flags Details

Description daniel.kermac 2015-10-10 12:46:30 UTC
Version-Release number of selected component:
ibus-1.5.11-1.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        ibus-daemon --xim --panel disable
crash_function: bus_dbus_impl_dispatch_message_by_rule
executable:     /usr/bin/ibus-daemon
global_pid:     2410
kernel:         4.2.2-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 bus_dbus_impl_dispatch_message_by_rule at dbusimpl.c:1901
 #5 bus_dbus_impl_connection_filter_cb at dbusimpl.c:1578
 #6 on_worker_message_about_to_be_sent at gdbusconnection.c:2343
 #7 _g_dbus_worker_emit_message_about_to_be_sent at gdbusprivate.c:465
 #8 continue_writing at gdbusprivate.c:1455
 #9 write_message_cb at gdbusprivate.c:1313
 #10 g_task_return_now at gtask.c:1104
 #11 complete_in_idle_cb at gtask.c:1118
 #16 gdbus_shared_thread_func at gdbusprivate.c:246
 #17 g_thread_proxy at gthread.c:778

Potential duplicate: bug 905044

Comment 1 daniel.kermac 2015-10-10 12:46:35 UTC
Created attachment 1081607 [details]
File: backtrace

Comment 2 daniel.kermac 2015-10-10 12:46:37 UTC
Created attachment 1081608 [details]
File: cgroup

Comment 3 daniel.kermac 2015-10-10 12:46:39 UTC
Created attachment 1081609 [details]
File: core_backtrace

Comment 4 daniel.kermac 2015-10-10 12:46:41 UTC
Created attachment 1081610 [details]
File: dso_list

Comment 5 daniel.kermac 2015-10-10 12:46:43 UTC
Created attachment 1081611 [details]
File: environ

Comment 6 daniel.kermac 2015-10-10 12:46:45 UTC
Created attachment 1081612 [details]
File: limits

Comment 7 daniel.kermac 2015-10-10 12:46:47 UTC
Created attachment 1081613 [details]
File: maps

Comment 8 daniel.kermac 2015-10-10 12:46:48 UTC
Created attachment 1081614 [details]
File: mountinfo

Comment 9 daniel.kermac 2015-10-10 12:46:50 UTC
Created attachment 1081615 [details]
File: namespaces

Comment 10 daniel.kermac 2015-10-10 12:46:52 UTC
Created attachment 1081616 [details]
File: open_fds

Comment 11 daniel.kermac 2015-10-10 12:46:54 UTC
Created attachment 1081617 [details]
File: proc_pid_status

Comment 12 fujiwara 2015-10-14 07:36:47 UTC
I cannot reproduce your backtrace.
Are you still able to reproduce your backtrace?

(In reply to daniel.kermac from comment #1)
> Created attachment 1081607 [details]
> File: backtrace

#0  0x00007fe995615a98 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:55
#1  0x00007fe99561769a in __GI_abort () at abort.c:89
#2  0x00007fe995c2ea15 in g_assertion_message (domain=domain@entry=0x563390b44b3a "IBUS", file=file@entry=0x563390b44fe6 "dbusimpl.c", line=line@entry=1901, func=func@entry=0x563390b45540 <__func__.26280> "bus_dbus_impl_dispatch_message_by_rule", message=message@entry=0x7fe980012f10 "assertion failed: (skip_connection == NULL || BUS_IS_CONNECTION (skip_connection))") at gtestutils.c:2429
#3  0x00007fe995c2eaaa in g_assertion_message_expr (domain=domain@entry=0x563390b44b3a "IBUS", file=file@entry=0x563390b44fe6 "dbusimpl.c", line=line@entry=1901, func=func@entry=0x563390b45540 <__func__.26280> "bus_dbus_impl_dispatch_message_by_rule", expr=expr@entry=0x563390b453c0 "skip_connection == NULL || BUS_IS_CONNECTION (skip_connection)") at gtestutils.c:2444
BUS_IS_CONNECTION (skip_connection))"
#4  0x0000563390b3469e in bus_dbus_impl_dispatch_message_by_rule (dbus=dbus@entry=0x563392ca7830, message=message@entry=0x7fe980004190, skip_connection=skip_connection@entry=0x563392d3e190) at dbusimpl.c:1901
>
#5  0x0000563390b34ab8 in bus_dbus_impl_connection_filter_cb (dbus_connection=<optimized out>, message=0x7fe980004190, incoming=<optimized out>, user_data=0x563392ca7830) at dbusimpl.c:1578

Comment 13 fujiwara 2015-11-20 07:48:36 UTC
If you still can reproduce the same backtrace, please comment it again here.

Comment 14 Vitaliy Gribko 2015-12-11 09:53:10 UTC
Yes,

I gotten several segfault with this error for four hours.

It reproduced after 15-30 minutes of hard work with c++ code.

Comment 15 Vitaliy Gribko 2015-12-11 09:59:20 UTC
Delete my comment above - I'm confused questions.

Comment 16 fujiwara 2015-12-14 02:41:41 UTC
(In reply to Vitaliy Gribko from comment #15)
> Delete my comment above - I'm confused questions.

I mean if you still reproduce the bug, you can test if a test binary can fix the bug.


Note You need to log in before you can comment on or make changes to this bug.