Bug 1270520 - dnf crash installing koji buildroot
dnf crash installing koji buildroot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
armhfp Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-10 09:43 EDT by Tom Hughes
Modified: 2015-10-12 04:33 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 04:33:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Hughes 2015-10-10 09:43:46 EDT
A koschei build of one my packages in koji failed when dnf crash installing the buildroot. Build is here:

  http://koji.fedoraproject.org/koji/taskinfo?taskID=11396458

and the full output is in the log at:

  https://kojipkgs.fedoraproject.org//work/tasks/6458/11396458/root.log

the actual traceback was:

DEBUG util.py:393:  Traceback (most recent call last):
DEBUG util.py:393:    File "/usr/bin/dnf", line 36, in <module>
DEBUG util.py:393:      main.user_main(sys.argv[1:], exit_code=True)
DEBUG util.py:393:    File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 185, in user_main
DEBUG util.py:393:      errcode = main(args)
DEBUG util.py:393:    File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
DEBUG util.py:393:      return _main(base, args)
DEBUG util.py:393:    File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 141, in _main
DEBUG util.py:393:      ret = resolving(cli, base)
DEBUG util.py:393:    File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 160, in resolving
DEBUG util.py:393:      base.do_transaction()
DEBUG util.py:393:    File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 217, in do_transaction
DEBUG util.py:393:      super(BaseCli, self).do_transaction(display)
DEBUG util.py:393:    File "/usr/lib/python2.7/site-packages/dnf/base.py", line 574, in do_transaction
DEBUG util.py:393:      self._run_transaction(cb=cb)
DEBUG util.py:393:    File "/usr/lib/python2.7/site-packages/dnf/base.py", line 696, in _run_transaction
DEBUG util.py:393:      self.verify_transaction(cb.verify_tsi_package)
DEBUG util.py:393:    File "/usr/lib/python2.7/site-packages/dnf/base.py", line 752, in verify_transaction
DEBUG util.py:393:      yumdb_info.releasever = self.conf.releasever
DEBUG util.py:393:    File "/usr/lib/python2.7/site-packages/dnf/yum/rpmsack.py", line 295, in __setattr__
DEBUG util.py:393:      self._write(attr, value)
DEBUG util.py:393:    File "/usr/lib/python2.7/site-packages/dnf/yum/rpmsack.py", line 232, in _write
DEBUG util.py:393:      dnf.pycomp.write_to_file(fo, value)
DEBUG util.py:393:    File "/usr/lib/python2.7/site-packages/dnf/pycomp.py", line 88, in write_to_file
DEBUG util.py:393:      f.write(content.encode('utf-8'))
DEBUG util.py:393:  AttributeError: 'NoneType' object has no attribute 'encode'
DEBUG util.py:515:  Child return code was: 1

This is also being tracked in the rel-eng trac at https://fedorahosted.org/rel-eng/ticket/6273.
Comment 1 Orion Poplawski 2015-10-10 10:10:52 EDT
I think this is only happening on arm.
Comment 2 Rex Dieter 2015-10-10 10:30:30 EDT
I can confirm the 2 failures I saw were arm too:
http://koji.fedoraproject.org/koji/taskinfo?taskID=11397288
http://koji.fedoraproject.org/koji/taskinfo?taskID=11389448
Comment 3 Kevin Fenzi 2015-10-10 14:32:27 EDT
and... the same arm builder. ;) 

going to go look at that one closely...
Comment 4 Kevin Fenzi 2015-10-10 16:23:06 EDT
I couldn't find anything wrong with it, but since it's easy I reinstalled it from scratch.
Comment 5 Tom Hughes 2015-10-10 19:39:21 EDT
I've had one fail on a different builder now, an x86 one in fact: http://koji.fedoraproject.org/koji/taskinfo?taskID=11404963

Backtrace is the same.
Comment 6 Paul Howarth 2015-10-11 07:47:42 EDT
Just had an i386 build fail on buildhw-11.phx2.fedoraproject.org

​http://koji.fedoraproject.org/koji/taskinfo?taskID=11406124

Looks the same. I maintain a lot of packages and I've been getting a lot of these over the last couple of days.
Comment 7 Miroslav Suchý 2015-10-12 03:46:41 EDT
This seems to be related to bug 1173107 as it is obviously trying to write releasever, which is unfortunately None.

What version of DNF is on those Koji builders?
Comment 8 Tom Hughes 2015-10-12 03:51:33 EDT
Per https://fedorahosted.org/rel-eng/ticket/6273#comment:8 it now seems that some of the builders were missing an update, and that installing it has fixed them, so we can probably close this.

Note You need to log in before you can comment on or make changes to this bug.