Bug 1270532 - Add support for GL_EXT_x11_sync_object
Add support for GL_EXT_x11_sync_object
Status: CLOSED DUPLICATE of bug 1258842
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter (Show other bugs)
7.2
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-10 15:57 EDT by Justin King
Modified: 2015-10-14 08:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-14 08:27:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin King 2015-10-10 15:57:56 EDT
Description of problem:

This problem is only reproducible when using the proprietary NVIDIA drivers and OpenGL rendering. It is especially apparent when using Firefox and other accelerated applications.

The problem is resolved by applying the following patches, in order as they appear, to mutter and bumping the release. I successfully did this with the RHEL 7.2 beta. 

https://git.gnome.org/browse/mutter/patch/src/compositor?id=47cb21b36c7f28c76c7f68b9a5c1d31daae2a0cb
https://git.gnome.org/browse/mutter/patch/src/compositor?id=662d50460bea2410cb278ab9e89356fb6263e4e2
https://git.gnome.org/browse/mutter/patch/src/compositor?id=9b1d436854bd353668565b921248f7e22671ea8d
https://git.gnome.org/browse/mutter/patch/src/compositor?id=461f193c006a96bc442e236b7ba932711efe861c

These commits landed in the mutter 3.14 branch on 2015-08-13 in response to a severe issue with rendering discussed here:

https://devtalk.nvidia.com/default/topic/729908/linux/-gt-334-21-redrawing-problems-in-gnome-3-10-3-12-gtx-580/7/

The issue essentially causes redraws to only complete partially. From what I saw this was due to a race condition caused by using proprietary drivers where XSync is not sufficient enough. The proprietary drivers are necessary when using Quadro graphics cards or CUDA.

The only workaround is to force clutter into continuous redrawing which is far from ideal.

Version-Release number of selected component (if applicable):

3.14.4-10

How reproducible:

Always.

Steps to Reproduce:
1. Install recent version of the NVIDIA graphics drivers for Linux.
2. Reboot.
3. Open a decent amount of tabs in Firefox and browse casually.

Actual results:

Partial redraws causing flashes and other graphical artifacts.

Expected results:

Properly redrawn graphics.

Additional info:

https://git.gnome.org/browse/mutter/log/src/compositor?h=gnome-3-14
https://git.gnome.org/browse/mutter/commit/?h=gnome-3-14&id=47cb21b36c7f28c76c7f68b9a5c1d31daae2a0cb
https://git.gnome.org/browse/mutter/commit/?h=gnome-3-14&id=662d50460bea2410cb278ab9e89356fb6263e4e2
https://git.gnome.org/browse/mutter/commit/?h=gnome-3-14&id=9b1d436854bd353668565b921248f7e22671ea8d
https://git.gnome.org/browse/mutter/commit/?h=gnome-3-14&id=461f193c006a96bc442e236b7ba932711efe861c
Comment 2 Rui Matos 2015-10-14 08:27:07 EDT
This should be included in mutter versions >= 3.14.4-11

*** This bug has been marked as a duplicate of bug 1258842 ***

Note You need to log in before you can comment on or make changes to this bug.