Bug 1270568 - smb fails to start
smb fails to start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
RejectedFreezeException
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-11 06:44 EDT by Nerijus Baliūnas
Modified: 2015-10-31 22:39 EDT (History)
9 users (show)

See Also:
Fixed In Version: samba-4.3.0-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-31 22:39:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nerijus Baliūnas 2015-10-11 06:44:32 EDT
After F22->23 upgrade smb fails to start:
# systemctl start smb
Job for smb.service failed because the control process exited with error code. See "systemctl status smb.service" and "journalctl -xe" for details.

# systemctl status smb
● smb.service - Samba SMB Daemon
   Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sk 2015-10-11 13:32:14 EEST; 4s ago
  Process: 2448 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=1/FAILURE)
 Main PID: 2448 (code=exited, status=1/FAILURE)

Spa 11 13:32:14 nerijus systemd[1]: Starting Samba SMB Daemon...
Spa 11 13:32:14 nerijus systemd[1]: smb.service: Main process exited, code=exited, status=1/FAILURE
Spa 11 13:32:14 nerijus systemd[1]: Failed to start Samba SMB Daemon.
Spa 11 13:32:14 nerijus systemd[1]: smb.service: Unit entered failed state.
Spa 11 13:32:14 nerijus systemd[1]: smb.service: Failed with result 'exit-code'.

Only after upgrading to samba-4.3.0-1.fc23.x86_64.rpm I got /var/log/samba/log. file, which said:
[2015/10/11 13:32:50.806509,  0] ../lib/util/util.c:285(directory_create_or_exist_strict)
  invalid permissions on directory '/var/lib/samba/msg': has 0700 should be 0755

Changing /var/lib/samba/msg permissions or deleting /var/lib/samba/msg directory allowed smb to start.
Comment 2 Fedora Update System 2015-10-12 10:00:44 EDT
samba-4.3.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ff4a6c72c7
Comment 3 Fedora Update System 2015-10-12 13:42:29 EDT
samba-4.3.0-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-40a82bc06a
Comment 4 Fedora Update System 2015-10-12 19:50:36 EDT
samba-4.3.0-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update samba'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-40a82bc06a
Comment 5 Fedora Update System 2015-10-12 19:50:46 EDT
samba-4.3.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update samba'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ff4a6c72c7
Comment 6 Fedora Blocker Bugs Application 2015-10-14 03:03:58 EDT
Proposed as a Freeze Exception for 23-final by Fedora user pwalter using the blocker tracking app because:

 Would be good to ship with working smb.service
Comment 7 Adam Williamson 2015-10-15 17:49:01 EDT
Discussed at 2015-10-15 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-15/f23-blocker-review.2015-10-15-20.11.log.txt . We tested, and it appears this is an upgrade-only issue: on a clean install of F23, the samba from current stable (0.1.rc4) starts up fine. Upgrades always use the repos anyway, so there's no need for a freeze exception to fix the upgrade case, hence this is rejected (the update can go out as a 0-day and upgrades on release day will work).
Comment 8 Fedora Update System 2015-10-31 22:39:28 EDT
samba-4.3.0-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.