Bug 1270584 - engine database has some missing indexes
engine database has some missing indexes
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Eli Mesika
Lukas Svaty
: CodeChange, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-11 09:05 EDT by Eli Mesika
Modified: 2016-02-18 06:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:06:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z?
rule-engine: planning_ack?
oourfali: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47179 master MERGED db: add missing indexes: Never
oVirt gerrit 47214 ovirt-engine-3.6 MERGED db: add missing indexes: Never

  None (edit)
Description Eli Mesika 2015-10-11 09:05:28 EDT
Description of problem:

PostgreSQL automatically creates indexes on primary keys and unique
constraints, but not on the referencing side of foreign key
relationships.

Since a DELETE of a row from the referenced table or an UPDATE of a
referenced column will require a scan of the referencing table for rows
matching the old value, it is often a good idea to index the referencing
columns.

Since oVirt mainly use the database for read operations, this may boost database performance
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:56:58 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Yaniv Lavi (Dary) 2015-10-29 08:39:45 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 3 Lukas Svaty 2016-01-21 10:09:23 EST
DB logs since previous versions does not contain any related issues. Performance of database queries did not decrease. Putting this bug to verified as sanity should be sufficient for this Code Change. Tested on rhevm-3.6.2.6-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.