Bug 1270601 - Cannot change user account email
Cannot change user account email
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: User Accounts (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-11 13:59 EDT by Shawn Iwinski
Modified: 2015-10-21 19:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 19:20:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Iwinski 2015-10-11 13:59:25 EDT
Description of problem: Cannot change email for user account


Version-Release number of selected component (if applicable): 4.4.9039-7


How reproducible: Try to change email for user account


Steps to Reproduce:
1. Log into bugzilla.redhat.com
2. Go to Preferences > Account information (https://bugzilla.redhat.com/userprefs.cgi?tab=account)
3. Change email


Actual results:

* Success message that email will be sent to new *and* old email account for verification
* No email to either old or new email address
* From https://bugzilla.redhat.com/userprefs.cgi?tab=account :
    Pending email address:	shawn@iwin.ski
    Change request expires:	2015-10-14 02:43 EDT


Expected results:

* Confirmation emails sent to both old and new email addresses


Additional info:

* I tried to update my email address from "shawn.iwinski@gmail.com" to "shawn@iwin.ski"
* I received an email from FAS to fix my bugzilla account because my email addresses did not match
* There is "resend confirmation emails" so I need to revert my FAS update until I can get my bugzilla user account updated
Comment 1 Shawn Iwinski 2015-10-11 14:00:49 EDT
Correction:
* There is NO "resend confirmation emails" option so I need to revert my FAS update until I can get my bugzilla user account updated
Comment 2 Muhammad Tahir 2015-10-14 00:14:24 EDT
Did you check your email filtering rules and spam folder? If you are still unable to find the confirmation email, please let us know.
Comment 3 Shawn Iwinski 2015-10-15 14:58:48 EDT
I found it -- I had it filtered.  THANKS!... and SORRY!

However, I get the error message "The token you submitted does not exist, has expired, or has been canceled." when I click the provided confirmation link and I cannot resubmit the change request because the "Change request expires:	2015-10-18 14:51 EDT" still displays on the account information page.  Is there a way to resend the confirmation email?
Comment 4 Muhammad Tahir 2015-10-15 19:35:53 EDT
Did the email mention that link would expire in X amount of time if not used?
Comment 5 Shawn Iwinski 2015-10-21 07:40:58 EDT
I was able to successfully change my email.  Thanks!
Comment 6 Shawn Iwinski 2015-10-21 08:10:37 EDT
I was able to successfully change my email.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.