Bug 1270604 - gnome-shell-extension-openweather not loading
gnome-shell-extension-openweather not loading
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-openweather (Show other bugs)
22
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jens Lody
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-11 15:02 EDT by Andre Robatino
Modified: 2015-11-20 18:24 EST (History)
2 users (show)

See Also:
Fixed In Version: gnome-shell-extension-openweather-1-0.10.20151108git6368d32.fc23 gnome-shell-extension-openweather-1-0.10.20151108git6368d32.fc22 gnome-shell-extension-openweather-1-0.10.20151108git6368d32.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 10:50:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2015-10-11 15:02:32 EDT
Description of problem:
For the past 2 days, gnome-shell-extension-openweather does not provide the weather forecast. It always says "Loading...". The F22 and F23 versions have not changed, so there is a problem with the server (API change, maybe?). I see there is a new Rawhide version, but unfortunately there is currently a problem with Rawhide preventing me from logging into GNOME, so I can't test it.

Version-Release number of selected component (if applicable):
gnome-shell-extension-openweather-1-0.4.20150924gite55253e.fc22.noarch

How reproducible:
always
Comment 1 Andre Robatino 2015-10-11 16:07:18 EDT
After registering at openweathermap.org and entering my personal API key in the preferences under Weather provider/Personal Api key from openweather.org, it's working again.
Comment 2 Andre Robatino 2015-10-11 16:45:44 EDT
I had to create a similar account at forecast.io in order to use that server, so they both changed policy at about the same time. Are the two sites related?
Comment 3 Jens Lody 2015-10-11 16:59:54 EDT
> I had to create a similar account at forecast.io in order to use that
> server, so they both changed policy at about the same time. Are the two
> sites related?
Forecast.io needed an api-key since I added them to the extension, but the service seems to be more stable and more precise, at least for the locations I use (several cities and small villages in germany over the year, depending on my work).

Openweathermap.org does no longer provide access without an api-key.
In the past they recommended it, now it's required.
The new version in the repo has an updated Readme.md in the docs, that reflects this.
Unfortunately, I can not do anything to work around this.

If anybody knows an xml-parser, that can be used from a gnome-shell-extension, I'll be happy to add met.no (yr.no) (In reply to Andre Robatino from comment #2)
Comment 4 Andre Robatino 2015-10-11 17:34:56 EDT
I thought that I had tried forecast.io without an API key before and that it worked, but I'm not sure. Anyway, I'm set now with accounts for both sites for redundancy. Since both sites now require an API key, if forecast.io is better you could make that one the default. Thanks for the info.
Comment 5 Flo H. 2015-10-13 16:02:48 EDT
Is there a way to get an API key without account?
Comment 6 Jens Lody 2015-10-13 23:59:58 EDT
(In reply to Florian Heiser from comment #5)
> Is there a way to get an API key without account?

Unfortunately not (as far as I know).
I would prefer something like a bulk api-key per application, but that would render the api-key useless I think.

Any ideas for other (free, of course) weather-providers are welcome, the same is for an xmlparser I can use inside a gnome-shell-extension.
I hope I find a working standalone xml2json-script, that does not require nodejs, a browser or whatever.
Comment 7 Flo H. 2015-10-14 15:24:40 EDT
Hi Jens, 
wanted to drop a big Dankeschön to you for coding this extension! I like it a lot - I guess the entire Gnome community does...
Thanks!
Comment 8 Andre Robatino 2015-10-16 18:31:08 EDT
For the last couple of hours, at least, the forecast from forecast.io does not load. If I switch over to openweathermap.org, it works immediately. (Using an API key with both.) It might be better to keep the latter as the default provider.
Comment 9 Jens Lody 2015-10-16 19:42:20 EDT
I already uploaded a fixed version.
It seems that forecast.io no longer allows non-https requests.

For the openweathermap-key, see: https://github.com/jenslody/gnome-shell-extension-openweather/issues/77#issuecomment-148759094
Comment 10 Fedora Update System 2015-11-08 06:57:56 EST
gnome-shell-extension-openweather-1-0.9.20151108gite4dbfee.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-398b4f8a1f
Comment 11 Fedora Update System 2015-11-08 06:58:58 EST
gnome-shell-extension-openweather-1-0.9.20151108gite4dbfee.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-25707d4952
Comment 12 Fedora Update System 2015-11-08 06:59:26 EST
gnome-shell-extension-openweather-1-0.9.20151108gite4dbfee.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-e01c272a9b
Comment 13 Fedora Update System 2015-11-08 07:19:55 EST
gnome-shell-extension-openweather-1-0.10.20151108git6368d32.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-79ea436c7c
Comment 14 Fedora Update System 2015-11-08 07:20:21 EST
gnome-shell-extension-openweather-1-0.10.20151108git6368d32.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-622a7320cf
Comment 15 Fedora Update System 2015-11-08 07:20:49 EST
gnome-shell-extension-openweather-1-0.10.20151108git6368d32.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-951169dc7a
Comment 16 Fedora Update System 2015-11-08 21:20:32 EST
gnome-shell-extension-openweather-1-0.10.20151108git6368d32.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gnome-shell-extension-openweather'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-951169dc7a
Comment 17 Fedora Update System 2015-11-08 22:50:04 EST
gnome-shell-extension-openweather-1-0.10.20151108git6368d32.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gnome-shell-extension-openweather'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-622a7320cf
Comment 18 Fedora Update System 2015-11-08 23:49:51 EST
gnome-shell-extension-openweather-1-0.10.20151108git6368d32.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gnome-shell-extension-openweather'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-79ea436c7c
Comment 19 Jens Lody 2015-11-09 20:18:19 EST
The new version does not need an API-key from openweathermap.org.
It ships with a default key, that was added to the FOSS-whitelist from openweathermap.org.
Comment 20 Fedora Update System 2015-11-17 10:50:46 EST
gnome-shell-extension-openweather-1-0.10.20151108git6368d32.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2015-11-17 13:22:27 EST
gnome-shell-extension-openweather-1-0.10.20151108git6368d32.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2015-11-20 18:24:03 EST
gnome-shell-extension-openweather-1-0.10.20151108git6368d32.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.