Bug 1270612 - [abrt] java-1.8.0-openjdk-headless: signalHandler(): java killed by SIGABRT
[abrt] java-1.8.0-openjdk-headless: signalHandler(): java killed by SIGABRT
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:3eba10322075d9b568a9fd04b6c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-11 17:05 EDT by Eric West
Modified: 2016-02-23 14:22 EST (History)
12 users (show)

See Also:
Fixed In Version: eclipse-4.5.1-12.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 14:22:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (44.83 KB, text/plain)
2015-10-11 17:05 EDT, Eric West
no flags Details
File: cgroup (188 bytes, text/plain)
2015-10-11 17:05 EDT, Eric West
no flags Details
File: core_backtrace (183.01 KB, text/plain)
2015-10-11 17:05 EDT, Eric West
no flags Details
File: dso_list (29.72 KB, text/plain)
2015-10-11 17:05 EDT, Eric West
no flags Details
File: environ (3.31 KB, text/plain)
2015-10-11 17:05 EDT, Eric West
no flags Details
File: limits (1.29 KB, text/plain)
2015-10-11 17:05 EDT, Eric West
no flags Details
File: maps (117.92 KB, text/plain)
2015-10-11 17:05 EDT, Eric West
no flags Details
File: mountinfo (3.12 KB, text/plain)
2015-10-11 17:05 EDT, Eric West
no flags Details
File: namespaces (85 bytes, text/plain)
2015-10-11 17:05 EDT, Eric West
no flags Details
File: open_fds (18.88 KB, text/plain)
2015-10-11 17:05 EDT, Eric West
no flags Details
File: proc_pid_status (1009 bytes, text/plain)
2015-10-11 17:05 EDT, Eric West
no flags Details
File: var_log_messages (342 bytes, text/plain)
2015-10-11 17:05 EDT, Eric West
no flags Details
hs_err file (159.75 KB, text/plain)
2015-10-14 18:40 EDT, Eric West
no flags Details

  None (edit)
Description Eric West 2015-10-11 17:05:43 EDT
Description of problem:
double clicked on HTML document (java 1.8 javadoc API index.html) in eclipse project explorer

Version-Release number of selected component:
java-1.8.0-openjdk-headless-1.8.0.60-14.b27.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /bin/java -Xms512m -Xmx8192m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dp2.fragments=/usr/share/eclipse/droplets,/usr/lib64/eclipse/droplets -Declipse.p2.skipMovedInstallDetection=true -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.100.v20151005-1500.jar -data file:/home/eric/sw/ -os linux -ws gtk -arch x86_64 -showsplash /usr/lib64/eclipse//plugins/org.eclipse.platform_4.5.1.v20151005-1500/splash.bmp -launcher /usr/lib64/eclipse/eclipse -name Eclipse --launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.300.v20151005-1500/eclipse_1613.so -startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.100.v20151005-1500.jar -protect master --launcher.appendVmargs -exitdata 1678000 -vm /bin/java -vmargs -Xms512m -Xmx8192m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dp2.fragments=/usr/share/eclipse/droplets,/usr/lib64/eclipse/droplets -Declipse.p2.skipMovedInstallDetection=true -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.100.v20151005-1500.jar
crash_function: signalHandler
executable:     /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.60-14.b27.fc23.x86_64/jre/bin/java
global_pid:     31858
kernel:         4.2.2-300.fc23.x86_64+debug
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #5 signalHandler at /usr/src/debug/java-1.8.0-openjdk-1.8.0.60-14.b27.fc23.x86_64/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:4222
 #7 webkit_web_view_draw at Source/WebKit/gtk/webkit/webkitwebview.cpp:724
 #8 _gtk_widget_draw_internal at gtkwidget.c:6831
 #10 _gtk_widget_draw_windows at gtkwidget.c:6933
 #11 _gtk_widget_draw at gtkwidget.c:7007
 #12 gtk_container_propagate_draw_internal at gtkcontainer.c:3797
 #13 gtk_container_draw at gtkcontainer.c:3666
 #14 gtk_scrolled_window_draw at gtkscrolledwindow.c:2352
 #15 _gtk_widget_draw_internal at gtkwidget.c:6831
 #17 _gtk_widget_draw_windows at gtkwidget.c:6933
Comment 1 Eric West 2015-10-11 17:05:47 EDT
Created attachment 1081808 [details]
File: backtrace
Comment 2 Eric West 2015-10-11 17:05:49 EDT
Created attachment 1081809 [details]
File: cgroup
Comment 3 Eric West 2015-10-11 17:05:50 EDT
Created attachment 1081810 [details]
File: core_backtrace
Comment 4 Eric West 2015-10-11 17:05:51 EDT
Created attachment 1081811 [details]
File: dso_list
Comment 5 Eric West 2015-10-11 17:05:52 EDT
Created attachment 1081812 [details]
File: environ
Comment 6 Eric West 2015-10-11 17:05:53 EDT
Created attachment 1081813 [details]
File: limits
Comment 7 Eric West 2015-10-11 17:05:54 EDT
Created attachment 1081814 [details]
File: maps
Comment 8 Eric West 2015-10-11 17:05:55 EDT
Created attachment 1081815 [details]
File: mountinfo
Comment 9 Eric West 2015-10-11 17:05:56 EDT
Created attachment 1081816 [details]
File: namespaces
Comment 10 Eric West 2015-10-11 17:05:58 EDT
Created attachment 1081817 [details]
File: open_fds
Comment 11 Eric West 2015-10-11 17:05:59 EDT
Created attachment 1081818 [details]
File: proc_pid_status
Comment 12 Eric West 2015-10-11 17:05:59 EDT
Created attachment 1081819 [details]
File: var_log_messages
Comment 13 Deepak Bhole 2015-10-14 13:55:43 EDT
Hi, looks like the GDB trace got cut off and it does not have enough information. Is this issue reproducible?
Comment 14 Eric West 2015-10-14 18:40:07 EDT
This is very reproducible.  Any time I double click on an HTML file in the package explorer, eclipse will crash.
Comment 15 Eric West 2015-10-14 18:40 EDT
Created attachment 1083040 [details]
hs_err file
Comment 16 Eric West 2015-10-14 18:54:38 EDT
One more update - If I change the eclipse.ini option --launcher.GTK_version
from 3 to 2, then the default web browser works fine.
Comment 17 Deepak Bhole 2015-10-16 12:06:57 EDT
Thanks for the hs_err file, it seems that the problem originated in native swt code. Re-assigning to the Eclipse team which might be able to help.
Comment 18 Fedora Update System 2016-02-17 10:07:32 EST
eclipse-4.5.1-12.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bfb1b334da
Comment 19 Fedora Update System 2016-02-17 17:30:56 EST
eclipse-4.5.1-12.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bfb1b334da
Comment 20 Fedora Update System 2016-02-23 14:22:07 EST
eclipse-4.5.1-12.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.