Bug 1270613 - Book titles for untranslated documentation on the landing page should be shown in English
Book titles for untranslated documentation on the landing page should be show...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: nobody nobody
Pavel Stehlik
ux
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-11 17:41 EDT by Yuko Katabami
Modified: 2015-10-14 03:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-14 02:40:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-shot: Missing Spanish documentation (19.39 KB, image/png)
2015-10-14 02:31 EDT, Einav Cohen
no flags Details

  None (edit)
Description Yuko Katabami 2015-10-11 17:41:29 EDT
Description of problem:
Although documentation are only translated into Japanese and Simplified Chinese, titles are translated in other languages (i.e. French, German, Spanish, Brazilian Portuguese, Korean).

Showing translated titles would be misleading for the users as they expect those books translated.

Version-Release number of selected component (if applicable): all


How reproducible: 100%


Steps to Reproduce:
1. Open the landing page
2. Select a locale other than English
3. Check the titles of books

Actual results:
Locales that do not have translated available have translated titles of books listed

Expected results:
They should appear in English

Additional info:
Comment 1 Yuko Katabami 2015-10-11 17:50:51 EDT
This was discussed a few years ago and at the time we agreed to keep it as-is, because the untranslated titles are linked to English documents (and assumed that users will find out that translation is not available), however, some translators pointed out during the QA event that they should be left in English if translation is not available, so that users do not expect to find them in the first place.

For reference, the Customer Portal product documentation site lists a translated title only if the book is translated, and the same rule should apply here as well.
Comment 3 Einav Cohen 2015-10-14 02:31 EDT
Created attachment 1082706 [details]
screen-shot: Missing Spanish documentation
Comment 4 Einav Cohen 2015-10-14 02:40:19 EDT
the text in the welcome page is displayed based on the selected locale. that includes the titles of the documentation files. 

if a documentation file in a certain locale doesn't exist and the English documentation is displayed instead, the user receives a message about it once he clicks on the documentation link (see attachment 1082706 [details] for the displayed message for missing Spanish docs, for example). 

I understand the confusion, however I think that the current state is perfectly acceptable and making the the proposed change will be too much effort for very little gain. closing.
Comment 5 Yuko Katabami 2015-10-14 03:02:35 EDT
No problems, Einav.
Thank you for explaining it again.

Note You need to log in before you can comment on or make changes to this bug.