Bug 1270619 - [DOCS] [3.1] [Feature] Document the non-interactive Installer for 3.1
[DOCS] [3.1] [Feature] Document the non-interactive Installer for 3.1
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Timothy
Gaoyun Pei
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-11 19:39 EDT by Vikram Goyal
Modified: 2017-03-08 13 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 20:11:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikram Goyal 2015-10-11 19:39:15 EDT
This is targeted to be done by 10/16 by the eng team.

The use case is to define a declared file (and format) for driving a non-interactive installation. 

The interface is classified as public and therefore can only be added to, but not removed.

Check with the productization team for more details.

To go in the Install and Config Guide.
Comment 3 Brenton Leanhardt 2015-10-16 09:17:20 EDT
The two stories that are relevant to this request are:

https://trello.com/c/j7vkAvTj/71-2-make-sure-oo-install-can-run-unattended
https://trello.com/c/fHy2DzMN/54-5-supported-installation-configuration-file-format

You should be able to see QE's test cases here for usage examples:

https://tcms.engineering.redhat.com/case/505048/?from_plan=14587

From reading the description I think the most important thing will be to document the installation tool's config format.  You can join that card and sync with Devan on the latest details.  The format is fairly stable now.  I suspect in a day or two Sam and Devan can give you a build you can try out for yourself.
Comment 4 Brenton Leanhardt 2015-10-16 09:18:57 EDT
One thing to clarify in QE's test cases.  They were written before the config file format was finalized.  Those tests will be updated once https://trello.com/c/fHy2DzMN/54-5-supported-installation-configuration-file-format is complete.  For now just sync with Devan on that card to get the latest config file details.
Comment 5 Timothy 2015-10-19 20:59:36 EDT
Thanks Brenton, I have reached out to Devan for details.
Comment 6 Timothy 2015-10-30 02:52:03 EDT
https://github.com/openshift/openshift-docs/pull/1126

Created docs pull request (WIP for now) containing full explanation of new non-interactive install configuration file format.

Waiting on details of how to use file, have pinged SME in Trello card: https://trello.com/c/fHy2DzMN
Comment 7 Timothy 2015-11-01 19:59:56 EST
Alex Dellapenta pulled my work into a new PR since it dove-tailed into something he was working on. 

My PR#1126 will be closed in favour of PR#1128.

Closing: https://github.com/openshift/openshift-docs/pull/1126

New PR: https://github.com/openshift/openshift-docs/pull/1128
Comment 8 Timothy 2015-11-01 20:14:59 EST
Got answer from SME in Trello card: https://trello.com/c/fHy2DzMN

Questions:

1. For "ansible_log_path", this was not defined in the sample you provided. If the user wanted to change this from the default, would it matter what line in the file this was written on? Should it go before or after the "hosts" section?

2. How does the user specify to use this file for an installation, once they've written the file?

Answers:

for (1) the ansible log path can go anywhere in the config file provided it's not indented like the hosts lines are. Typically it would be written before the hosts line but it doesn't really matter.

For (2) if the default location is used, it will automatically be read and re-used the next time the user runs the installation. Same holds true if they use a different location with -c, they just have to provide the same -c again on each run.
Comment 9 Timothy 2015-11-01 20:27:18 EST
Added comments into Alex's PR#1128 since I'm not sure how to pull his PR, make changes, and push back to his fork. I don't think that's possible unless he gives me permissions on his personal GitHub fork.
Comment 11 Timothy 2015-11-06 00:18:44 EST
Submitted new PR to include "version", which was recently added to this installation configuration file specification:

https://github.com/openshift/openshift-docs/pull/1158

I think that should do it. Moving to QA.
Comment 19 Timothy 2015-11-11 19:47:54 EST
https://github.com/openshift/openshift-docs/pull/1175

^ this commit makes the final changes for this bug. 

This has passed QE. 

This bug is verified.
Comment 20 Timothy 2015-11-12 01:32:42 EST
This has merged, moving to RELEASE PENDING

Note You need to log in before you can comment on or make changes to this bug.