Bug 127065 - Specific Pentium 4 and P4 SMT kernel builds for FC2
Specific Pentium 4 and P4 SMT kernel builds for FC2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-01 07:47 EDT by Andrea Santilli
Modified: 2015-01-04 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 18:12:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Santilli 2004-07-01 07:47:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040618 Firefox/0.9

Description of problem:
This is not a bug but a wish. Unlike in fc1, if I recompile the kernel
for Pentium 4 its performance slightly increases comparing it to i686
plain versions in fc2. It isn't so in fc1, where the i686 version
appears to be faster than the P4 version. So, I think it would be a
great idea if you build specific RPMs for Pentium 4 and Pentium HT
processors...

Version-Release number of selected component (if applicable):
all fedora core 2 kernels

How reproducible:
Always

Steps to Reproduce:
1.install the i686 kernel build
2.recompile it changing the processor type to Pentium 4
3.The recompiled version is faster!
    

Actual Results:  P4 builds are faster than i686 builds

Expected Results:  to release specific P4 and P4SMT builds or at least
a i686 version that is faster than the P4 version.

Additional info:
Comment 1 Barry K. Nathan 2004-07-14 06:01:25 EDT
Do you have any numbers to show that a P4-specific build is faster?

Note You need to log in before you can comment on or make changes to this bug.