Bug 1270694 - Introduce priv dump in shard xlator for better debugging
Introduce priv dump in shard xlator for better debugging
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: sharding (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
:
Depends On:
Blocks: 1271204
  Show dependency treegraph
 
Reported: 2015-10-12 03:42 EDT by Krutika Dhananjay
Modified: 2016-06-16 09:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1271204 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:39:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2015-10-12 03:42:52 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-10-12 03:50:22 EDT
REVIEW: http://review.gluster.org/12334 (features/shard: Dump private members and addresses in statedump) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Krutika Dhananjay 2015-10-12 03:51:04 EDT
http://review.gluster.org/#/c/12334/
Comment 3 Vijay Bellur 2015-10-12 06:31:22 EDT
REVIEW: http://review.gluster.org/12340 (features/shard: Return ENOTSUP as opposed to ENOTCONN in unimplemented fops) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 4 Vijay Bellur 2015-10-12 08:18:27 EDT
REVIEW: http://review.gluster.org/12334 (features/shard: Dump private members and addresses in statedump) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 5 Vijay Bellur 2015-10-13 03:07:25 EDT
REVIEW: http://review.gluster.org/12340 (features/shard: Return ENOTSUP as opposed to ENOTCONN in unimplemented fops) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 6 Vijay Bellur 2015-10-13 07:29:52 EDT
COMMIT: http://review.gluster.org/12334 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit aa71df19383ac15306374ea4992dd59e20f5a9c5
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Mon Oct 12 13:12:46 2015 +0530

    features/shard: Dump private members and addresses in statedump
    
    Change-Id: I3c5e5bd93288c4c9a2665a26c0d6a76e67ecf914
    BUG: 1270694
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12334
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 7 Vijay Bellur 2015-10-13 07:30:48 EDT
COMMIT: http://review.gluster.org/12340 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 041d31e90b6000643e8c06a6d82520e3f2cc3b9a
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed Jul 29 14:27:07 2015 +0530

    features/shard: Return ENOTSUP as opposed to ENOTCONN in unimplemented fops
    
    Change-Id: Idba1070b11c5c1de26ef57e6843c93c105b8b8a5
    BUG: 1270694
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12340
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 8 Niels de Vos 2016-06-16 09:39:57 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.