This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1270704 - Configurable Workbench: VFS API does not work on Windows system
Configurable Workbench: VFS API does not work on Windows system
Status: CLOSED NOTABUG
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
Unspecified Windows
high Severity high
: ---
: ---
Assigned To: Eder Ignatowicz
Tomas David
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 04:14 EDT by Tomas David
Modified: 2015-10-19 02:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 02:17:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas David 2015-10-12 04:14:01 EDT
Description of problem:
VFS API cannot read ($vfs_readAllString) or write ($vfs_write) files on Windows machine. There is probably some problem with uri of command.

Version-Release number of selected component (if applicable):
6.2.0.ER3

How reproducible:
-

Steps to Reproduce:
1. Execute command $vfs_write("file://C:/.../testWriteFile.txt", "This is write test file.", function(a){}); in plugin or directly from js browser console.
2. Open created file 

Actual results:
File does not exist. 

Expected results:
File contains "This is write test file." string.

Additional info:
-
Comment 1 manstis 2015-10-12 05:14:26 EDT
Looks like the VFS JSNI exposure for plugins?
Comment 2 Eder Ignatowicz 2015-10-16 14:19:44 EDT
HI Tomas,

The JS API don't access local files. It only stores and read files in workbench repositories. 

In order to use the API (fstype://branch@repo/pathToFile): 

$vfs_write("default://master@system/sample.txt", "This is write test file.", function(success){
	alert(success);
});
'


$vfs_readAllString("default://master@system/sample.txt", function(content) { 
alert(content);
});
Comment 3 Tomas David 2015-10-19 02:17:20 EDT
Hi Eder,

thanks for explanation. My bad. Works on Windows.

Note You need to log in before you can comment on or make changes to this bug.