Bug 1270712 - Maybe enable syntax highlight by default?
Maybe enable syntax highlight by default?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nano (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kamil Dudka
Fedora Extras Quality Assurance
: EasyFix, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 04:54 EDT by Milan Crha
Modified: 2015-11-17 13:23 EST (History)
4 users (show)

See Also:
Fixed In Version: nano-2.4.2-2.fc24 nano-2.4.2-2.fc23 nano-2.3.6-7.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-08 01:51:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Crha 2015-10-12 04:54:59 EDT
I'm wondering whether it would make sense to enable syntax highligh by default for nano. I realized by an accident that it knows this too when I run it in a different distribution. The change is simple, the /etc/nanorc file line with:

# include "/usr/share/nano/*.nanorc"

should be uncommented.

I'm only suggesting this, not requesting, because I do not know whether there's any historical reason to have the syntax highlight disabled by default in Fedora or not.
Comment 1 Kamil Dudka 2015-10-12 06:19:40 EDT
I am not aware of any historical reason not to enable nano syntax highlighting by default.  It is just because upstream does not enable it by default.  I will change the configuration file as you suggest.  Unless anybody objects, I will do it only in rawhide so that users of stable Fedora do not need to merge their own changes of the configuration file.
Comment 2 Milan Crha 2015-10-12 06:43:09 EDT
(In reply to Kamil Dudka from comment #1)
> I will change the configuration file as you suggest.

Thanks.

> Unless anybody objects, I will do it only in rawhide so that users of stable
> Fedora do not need to merge their own changes of the configuration file.

I agree with this approach.
Comment 3 Kamil Dudka 2015-10-12 08:11:56 EDT
Fixed in nano-2.4.2-2.fc24 via:

http://pkgs.fedoraproject.org/cgit/nano.git/commit/?id=8a7d2e47
Comment 4 Harald Reindl 2015-11-04 08:39:20 EST
can we have this please for F22 or at least F23 too?
Comment 5 Kamil Dudka 2015-11-04 08:51:27 EST
(In reply to Harald Reindl from comment #4)
> can we have this please for F22 or at least F23 too?

Is not it easier to just change the config file?

Even if we distributed an update of nano with changed config file, it would not take an immediate effect in case a user has any local changes to that config file.
Comment 6 Harald Reindl 2015-11-04 08:54:07 EST
well, in that case it don't change anything, but i guess most users don't have a local configuration since i use nano for 8 years now on a dozens of machines and never touched the global config file nor one in the userhome

i just updated yesterday my rawhide-vm to current rawhide and said "wow" after opening a shellscript
Comment 7 Kamil Dudka 2015-11-04 09:00:34 EST
Fair enough.  I will submit the updates...
Comment 8 Fedora Update System 2015-11-04 09:18:01 EST
nano-2.4.2-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-461bb4fd21
Comment 9 Milan Crha 2015-11-04 11:17:07 EST
(In reply to Harald Reindl from comment #6)
> i just updated yesterday my rawhide-vm to current rawhide and said "wow"
> after opening a shellscript

Yeah, similar here. Do not ask how I realized that the 'nano' editor is not a 'nano' at all. :)
Comment 10 Fedora Update System 2015-11-04 20:28:03 EST
nano-2.4.2-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update nano'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-461bb4fd21
Comment 11 Fedora Update System 2015-11-05 10:52:46 EST
nano-2.3.6-7.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update nano'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-0dcf1576d6
Comment 12 Fedora Update System 2015-11-08 01:51:14 EST
nano-2.4.2-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2015-11-17 13:23:36 EST
nano-2.3.6-7.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.