Bug 1270723 - [RFE] Add an option to automatically accept defaults
[RFE] Add an option to automatically accept defaults
Status: CLOSED DUPLICATE of bug 1270719
Product: ovirt-engine
Classification: oVirt
Component: Setup.Core (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Sandro Bonazzola
Pavel Stehlik
integration
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 05:16 EDT by Yedidyah Bar David
Modified: 2015-10-12 05:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 05:24:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Yedidyah Bar David 2015-10-12 05:16:03 EDT
Description of problem:

Various places, including CI/QE and the engine appliance, maintain answer files
for engine-setup, in order to achieve unattended setup. This breaks whenever
a new question is added to engine-setup.

It will be helpful if we add an option called '--accept-defaults' which will
make engine-setup prompt only for questions for which it does not supply a
default, accepting the defaults for all of the others.

We should consider doing this change also in related tools - engine-cleanup,
ovirt-engine-rename, hosted-engine setup, etc. We will probably need to
change otopi, perhaps even only otopi.

This is of course also useful for normal interactive use, in case the user
knows that the defaults are ok.
Comment 1 Yedidyah Bar David 2015-10-12 05:24:07 EDT
Created accidentally due to some bugzilla issue.

*** This bug has been marked as a duplicate of bug 1270719 ***

Note You need to log in before you can comment on or make changes to this bug.