Bug 1270736 - An error occurred to change the hostname in second time
An error occurred to change the hostname in second time
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ovirt-3.6.1
: 3.6.0
Assigned To: Douglas Schilling Landgraf
cshao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 05:38 EDT by yileye
Modified: 2016-03-09 09:40 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-3.6.0-0.22.20151126git72acbb2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:40:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (1.23 MB, image/jpeg)
2015-10-12 05:38 EDT, yileye
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48392 master MERGED defaults: unpersist /etc/hostname to change hostname Never
oVirt gerrit 48804 master MERGED semodule: Avoid AVC for replacing hostname Never
oVirt gerrit 48976 ovirt-3.6 MERGED defaults: unpersist /etc/hostname to change hostname Never
oVirt gerrit 49030 ovirt-3.6 MERGED semodule: Avoid AVC for replacing hostname Never

  None (edit)
Description yileye 2015-10-12 05:38:38 EDT
Created attachment 1081933 [details]
Screenshot

Description of problem:
An error occurred to change the hostname in second time 

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20151009.0.iso
ovirt-node-3.3.0-0.13.20151008git03eefb5.el7ev.noarch


How reproducible:
100%

Steps to Reproduce:
1.Boot with PXE.
2.TUI clean install rhev-hypervisor7-7.2-20151009.0.iso with no error.
3.Enable NIC via DHCP and enable ssh.  
4.Enter 'NETWORK' page,and change the hostname. 
5.Click 'save' with no error.
6.Change the hostname again.
7.Click 'save'.

Actual results:
after step 7.output some error message:

Transaction: Network Interface Configuration                                                                                              │
│                                                                                                                                          │
│                                                                                                                                          │
│Checking pre-conditions ...                                                                                                               │
│(1/1) Setting hostname                                                                                                                    │
│                                                                                                                                          │
│An error occurred while applying the changes:                                                                                             │
│Command '['hostnamectl', 'set-hostname', 'hp-z600-03.qe.lab.eng.nay.redhat.com']' returned non-zero exit status 1                    

Expected results:
Change hostname can successful.

Additional info:
Comment 1 Fabian Deutsch 2015-10-12 06:14:04 EDT
The issues is maybe that /etc/hostname is persisted (and bind-mounted) while hostanemctl is called
Comment 2 yileye 2015-10-12 06:19:15 EDT
Maybe ‘hostanemctl’ has no jurisdiction here
Comment 11 yileye 2015-12-01 22:42:48 EST
Test version:
Red Hat Enterprise Virtualization Hypervisor (Beta) release 7.2 (20151201.1.el7ev)
ovirt-node-3.6.0-0.23.20151201git5eed7af.el7ev.noarch

Steps to Reproduce:
1.Boot with PXE.
2.TUI clean install RHEVH 7.2-20151201.1.el7ev with no error.
3.Enable NIC via DHCP and enable ssh.  
4.Enter 'NETWORK' page, and change the hostname. 
5.Click 'save' with no error.
6.Change the hostname again.
7.Click 'save'.

Actual results:
After step 7. INFO Changes were merged successfully


So the bug is fixed, change bug status to VERIFIED.
Comment 15 errata-xmlrpc 2016-03-09 09:40:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.