Bug 1270745 - virt-sysprep got segmentation fault with ppc64le guest image
virt-sysprep got segmentation fault with ppc64le guest image
Status: CLOSED DUPLICATE of bug 1224676
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.2
ppc64le Linux
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 05:50 EDT by Wayne Sun
Modified: 2015-10-12 07:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 07:14:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Sun 2015-10-12 05:50:13 EDT
Description of problem:
virt-sysprep got segmentation fault on ppc64le host with a rhel7.2 ppc64le guest image. 

Version-Release number of selected component (if applicable):
# rpm -q libguestfs libguestfs-tools libvirt
libguestfs-1.28.1-1.35.el7.ppc64le
libguestfs-tools-1.28.1-1.35.el7.noarch
libvirt-1.2.17-13.el7.ppc64le

How reproducible:
always

Steps to Reproduce:
1. run virt-sysprep with
# virt-sysprep -a /var/lib/libvirt/images/jeos-19-64.qcow2  -n --operations defaults,-ssh-hostkeys -v -x
[   0.0] Examining the guest ...
libguestfs: trace: set_verbose true
libguestfs: trace: set_verbose = 0
Segmentation fault


2.
3.

Actual results:
fail

Expected results:
succeed

Additional info:
# qemu-img info /var/lib/libvirt/images/jeos-19-64.qcow2 
image: /var/lib/libvirt/images/jeos-19-64.qcow2
file format: qcow2
virtual size: 8.0G (8589934592 bytes)
disk size: 8.0G
cluster_size: 65536
Format specific information:
    compat: 1.1
    lazy refcounts: true
    refcount bits: 16
    corrupt: false

guest with the image could be started.
Comment 2 Wayne Sun 2015-10-12 07:14:17 EDT

*** This bug has been marked as a duplicate of bug 1224676 ***

Note You need to log in before you can comment on or make changes to this bug.