Bug 1270789 - Missing environment parameter in puppet document.
Missing environment parameter in puppet document.
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs User Guide (Show other bugs)
6.1.2
All All
medium Severity medium (vote)
: Beta
: 6.2
Assigned To: Brandi
Lucie Jirakova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 07:58 EDT by Ranjan Kumar
Modified: 2016-11-11 16:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-11 16:09:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ranjan Kumar 2015-10-12 07:58:55 EDT
Document URL: https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/pdf/User_Guide/Red_Hat_Satellite-6.1-User_Guide-en-US.pdf

Section Number and Name: 12.6, Configuring the Puppet Agent 

Describe the issue: 
puppet "environment" is missing in agent section of puppet.conf configuration.

Suggestions for improvement: 
For correct syntax please refer:
https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html-single/Puppet_Guide/index.html#sect-Red_Hat_Satellite-Puppet_Guide-Applying_Configuration_on_Clients-Applying_Configuration_to_Existing_Clients 

Additional information: 
If environment is not set puppet agent throws warning 
Local environment: "production" doesn't match server specified node environment "KT_Environment", switching agent to "KT_Environment".
 
Here is sample 
[agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion.  Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt
    pluginsync = true
    report = true
    ignoreschedules = true
    daemon = false
    ca_server = satellite.example.com
    server = satellite.example.com
    environment = KT_Example_Org_Library_RHEL6Server_3

    # Where puppetd caches the local configuration.  An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig
Comment 1 Douglas Furlong 2015-10-13 05:43:53 EDT
Just to confirm.

This is the case when using puppet 2.7.23.2.el5sat, I'm assuming it's the case with the RHEL5 version of the client, and RHEL6 works fine without the Environment being set.
Comment 2 Andrew Dahms 2016-02-19 01:00:11 EST
Assigning to Brandi for review.

Brandi - looks like a quick fix to either add the 'environment' variable to the example in the documentation or a 'Note' box if it only applies to a specific version of RHEL, but we may need to raise a needinfo here to confirm this first.

Note You need to log in before you can comment on or make changes to this bug.