Bug 1270805 - Glance client returning 'Expected endpoint'
Glance client returning 'Expected endpoint'
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: rdo-manager (Show other bugs)
Liberty
Unspecified Unspecified
unspecified Severity high
: ---
: Liberty
Assigned To: Hugh Brock
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 08:27 EDT by Marius Cornea
Modified: 2017-06-18 02:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-18 02:25:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1504058 None None None Never

  None (edit)
Description Marius Cornea 2015-10-12 08:27:53 EDT
Description of problem:
When using the glance client for creating an image it returns 'Expected endpoint'.

Version-Release number of selected component (if applicable):
python-glance-store-0.9.2-dev6.el7.centos.noarch
openstack-glance-11.0.0.0-rc2.dev6.el7.centos.noarch
python-glanceclient-1.1.1-dev8.el7.centos.noarch
python-glance-11.0.0.0-rc2.dev6.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Follow the docs on https://repos.fedorapeople.org/repos/openstack-m/rdo-manager-docs/liberty
2. Deploy overcloud with one compute, one controller:
 openstack overcloud deploy --templates --libvirt-type qemu
3. glance --debug image-create --name Fedora22 --file Fedora-Cloud-Base-22-20150521.x86_64.qcow2  --disk-format qcow2 --container-format bare --visibility public --progress

Actual results:
[stack@instack ~]$ glance --debug image-create --name Fedora22 --file Fedora-Cloud-Base-22-20150521.x86_64.qcow2  --disk-format qcow2 --container-format bare --visibility public --progress 
Expected endpoint

Expected results:
Image gets created.

Additional info:
Workaround was to use the openstack client to create the image:
openstack image create --file Fedora-Cloud-Base-22-20150521.x86_64.qcow2 --public Fedora22
Comment 1 Flavio Percoco 2015-10-19 06:28:16 EDT
This is probably related to the linked bug, which is fixed in both master and liberty.

Note that a new liberty release might be needed.
Comment 4 Christopher Brown 2017-06-17 13:20:21 EDT
This is long-since fixed so can be closed.

Note You need to log in before you can comment on or make changes to this bug.