Bug 1270829 - Missing character encoding of internal resource bundle files in dashbuilder
Missing character encoding of internal resource bundle files in dashbuilder
Status: CLOSED DUPLICATE of bug 1200333
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.1.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: David Gutierrez
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 09:19 EDT by Martin Weiler
Modified: 2015-10-13 13:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 13:50:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Weiler 2015-10-12 09:19:13 EDT
Description of problem:
When switching the language to Spanish or German, special characters in the menu are not displayed properly

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start BPMS 6.1 and navigate to http://localhost:8080/dashbuilder/
2. Log in and switch to Spanish language
3. Some characters (eg. in 'Página:' at the middle header of the page) are displayed garbled. The same applies when hovering with the mouse over the edit icons)

Actual results:
Special characters are displayed incorrectly

Expected results:
All characters are displayed correctly

Additional info:
The *.properties files are not IS0-8859-1 encoded as they should be:
http://docs.oracle.com/javase/7/docs/api/java/util/PropertyResourceBundle.html

Eg. the entries in messages_en.properties should be ISO-8859-1 encoded like this:
> ui.sections.deleteCurrent=Borrar p\u00e1gina actual

instead of:
< ui.sections.deleteCurrent=Borrar página actual

See also: http://docs.oracle.com/javase/7/docs/technotes/tools/windows/native2ascii.html
Comment 1 Roger Martínez 2015-10-13 13:50:21 EDT
Hello,

This issue has been already identified and fixed on the latest version. We used native2ascii plugin to encode all the i18n properties files at package time -> 

https://github.com/droolsjbpm/dashboard-builder/commit/72e2224069d52214a1c200858aa7627b25906bd4

Marked as duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1200333

Thanks

*** This bug has been marked as a duplicate of bug 1200333 ***

Note You need to log in before you can comment on or make changes to this bug.