Bug 1270870 - click for picture, get wallpapered
click for picture, get wallpapered
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 10:53 EDT by Ray Holme
Modified: 2015-10-15 11:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 11:43:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Holme 2015-10-12 10:53:51 EDT
Description of problem: when viewing and opening a picture, it often becomes the new background (wallpaper now) - despite that I never asked to do that.


Version-Release number of selected component (if applicable): 3.16.5 evolution


How reproducible: Happened two times in last two days (two 64 bit machines)


Steps to Reproduce:
1. read email with picture (one was a .jpeg; one was a .xcf)
2. double click to see picture (in tool)
3. get tool and wallpaper (need to reset latter)

Actual results: My background is set to the new picture


Expected results: just a tool to view the picture


Additional info: I never saw this before, just upgraded all software last Sat. - now Fedora vmlinuz-4.1.10-200.fc22.x86_64 is the kernel
Comment 1 Milan Crha 2015-10-15 02:34:55 EDT
Thanks for a bug report. I'm not able to reproduce this, double-clicking the image attachment in the expanded attachment bar below the message headers in the message preview opens it in the associated application and doesn't change the background.

Could you try to right-click the image and choose to open it in one of the offered applications, please? It should do the same thing as the double-click. If the background will be set too, then it can mean that the external application set it, not the evolution. I know it's unlikely, but I'd like to verify it.
Comment 2 Ray Holme 2015-10-15 07:54:31 EDT
I tried to do this on both machines which had the problem. Both double click and right click menu. It did not happen. I noticed that the second option on a right click was to set the image as the background. Perhaps we right clicked and moved down one. Apologies. I will watch for it again. It has occurred but it might have been user fickle finger.

Feel free to close and apologies.
Comment 3 Milan Crha 2015-10-15 11:43:09 EDT
No problem. I'd guess you also face (a variation of) bug [1], but it's only a guess. Let's close this and eventually continue in the upstream bug report, if it's it.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=591258

Note You need to log in before you can comment on or make changes to this bug.