Bug 1270894 - Scrollbar arrows are missing KDE
Scrollbar arrows are missing KDE
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kf5-kwindowsystem (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Grulich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 11:37 EDT by Brian Kaye
Modified: 2016-02-09 17:50 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 10:03:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Kaye 2015-10-12 11:37:27 EDT
Description of problem: KDE Desktop issue. After upgrade from Fedora 20 to 22 using fedup, most applications no not have the arrows that were at the top and bottom of the scrollbars. This allowed fine grained movement which is not possible with dragging on large lists.



Version-Release number of selected component (if applicable):

Whatever came with Fedora 22 plus any subsequent upgrades afte September 22, 2015
How reproducible:

On all applications I have tried.
Steps to Reproduce:
1.Open an application that needs to have a scrollbar (eg. Firefox)
2.
3.

Actual results:
No arrows.

Expected results:
Arrows at top and bottom of scrollbars.

Additional info:
After upgrade many packages in the rpm database are show to be at the FC21 level
Comment 1 Rex Dieter 2015-10-12 12:14:39 EDT
firefox happens to be a gtk3 app whose styling is definitely different than f20 (due to oxygen-gtk3 no longer being present).  So, a different look is not unexpected (and I confirmed the default gtk3 style, adwaita, does not have arrows)

Any other non gtk3 apps where this is an issue?
Comment 2 Brian Kaye 2015-10-12 18:07:32 EDT
Most had the issue. I  just finished creating a new user and the problem was not there. I  then saved .kde and .config in my account and when new ones were created the problem was not there. So whatever happened was part of the upgrade process and not KDE.

The only one that I tried that actually had the scrollbars was Dolphin. 

Just need to find how to put the double arrows on the scrollbars.

So for me the problem is solved
Comment 5 Brian Kaye 2015-11-02 09:59:22 EST
How does one know which applications are gtk3? Not all of know the details of KDE terminology. As far as I can remember all the applications  used to have the scroll arrows. Now some do and some do not. Firefox used to have them and now it does not.
Comment 6 Rex Dieter 2015-11-02 10:03:06 EST
There is no easy/obvious way.

One less obvious way, using firefox as an example, if this gets any hits:

rpm -qR firefox | grep gtk-3

For example, on my f23 box I get:

$ rpm -qR firefox | grep gtk-3
libgtk-3.so.0()(64bit)


closing per comment #3
Comment 7 David Hladky 2016-02-09 07:45:09 EST
I have exactly the same issue on F23. I upgraded from F20 as well. The result 

libgtk-3.so.0()(64bit)

Is there any workaround how to fix the issue?
Comment 8 Rex Dieter 2016-02-09 17:50:47 EST
Change your gtk theming to use something other than (default) adwaita, or try adjusting adwaita to include them, using something like:
https://bbs.archlinux.org/viewtopic.php?id=157386

Note You need to log in before you can comment on or make changes to this bug.