Bug 1270956 - Error: Could not find class ::ironic::inspector for instack on node instack
Error: Could not find class ::ironic::inspector for instack on node instack
Status: CLOSED DUPLICATE of bug 1270957
Product: RDO
Classification: Community
Component: rdo-manager (Show other bugs)
Liberty
Unspecified Unspecified
unspecified Severity high
: ---
: Kilo
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 14:26 EDT by Marius Cornea
Modified: 2016-04-18 02:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 14:33:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-10-12 14:26:19 EDT
Description of problem:
Undercloud installation fails with the following message:
Error: Could not find class ::ironic::inspector for instack on node instack

Version-Release number of selected component (if applicable):
openstack-tripleo-puppet-elements-0.0.2-dev13.el7.centos.noarch
openstack-puppet-modules-2015.2-dev.232f6155275c8defe1d50c675d702041c108cb30_8eef2746.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run undercloud installation following the docs at https://repos.fedorapeople.org/repos/openstack-m/rdo-manager-docs/liberty/installation/installing.html


Actual results:
Installation fails:
Error: Could not find class ::ironic::inspector for instack on node instack

Expected results:
Installation completes ok

Additional info:
Workaround is to run 'export DIB_INSTALLTYPE_puppet_modules=source' before the 'openstack undercloud install' step.
Comment 1 Marius Cornea 2015-10-12 14:33:47 EDT

*** This bug has been marked as a duplicate of bug 1270957 ***

Note You need to log in before you can comment on or make changes to this bug.