Bug 1270964 - Stopped Neutron related pacemaker resources on overcloud controller
Stopped Neutron related pacemaker resources on overcloud controller
Status: CLOSED DUPLICATE of bug 1270325
Product: RDO
Classification: Community
Component: rdo-manager (Show other bugs)
Liberty
Unspecified Unspecified
high Severity high
: GA
: Liberty
Assigned To: Jay Dobies
yeylon@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 14:51 EDT by Marius Cornea
Modified: 2016-04-18 02:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 15:09:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-10-12 14:51:39 EDT
Description of problem:
I am running a 1 x ctrl + 1 x compute deployment with network isolation. After deploying overcloud some of the Neutron related pacemaker resources are stopped:
neutron-l3-agent-clone
neutron-metadata-agent-clone
neutron-ovs-cleanup-clone
neutron-netns-cleanup-clone
neutron-dhcp-agent-clone
neutron-openvswitch-agent-clone 

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.7-dev277.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Follow the docs for undercloud installtion on https://repos.fedorapeople.org/repos/openstack-m/rdo-manager-docs/liberty/
2. Deploy overcloud by using network isolation and configuring pacemaker on the controller:
openstack overcloud deploy --templates ~/templates/my-overcloud -e ~/templates/my-overcloud/environments/network-isolation.yaml -e ~/templates/network-environment.yaml --control-scale 1 --compute-scale 1 --libvirt-type qemu -e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml

Actual results:
Deployment succeds but some of the Neutron resources are stopped:
[root@overcloud-controller-0 heat-admin]# pcs status | grep -B1 Stopped
 Clone Set: neutron-l3-agent-clone [neutron-l3-agent]
     Stopped: [ overcloud-controller-0 ]
--
 Clone Set: neutron-metadata-agent-clone [neutron-metadata-agent]
     Stopped: [ overcloud-controller-0 ]
 Clone Set: neutron-ovs-cleanup-clone [neutron-ovs-cleanup]
     Stopped: [ overcloud-controller-0 ]
 Clone Set: neutron-netns-cleanup-clone [neutron-netns-cleanup]
     Stopped: [ overcloud-controller-0 ]
--
 Clone Set: neutron-dhcp-agent-clone [neutron-dhcp-agent]
     Stopped: [ overcloud-controller-0 ]
--
 Clone Set: neutron-openvswitch-agent-clone [neutron-openvswitch-agent]
     Stopped: [ overcloud-controller-0 ]

Expected results:
All resources are started.

Additional info:
The neutron-server is running:
[root@overcloud-controller-0 ~]# pcs status | grep -A1 neutron-server
 Clone Set: neutron-server-clone [neutron-server]
     Started: [ overcloud-controller-0 ]
[root@overcloud-controller-0 ~]# systemctl status neutron-server
neutron-server.service - OpenStack Neutron Server
   Loaded: loaded (/usr/lib/systemd/system/neutron-server.service; disabled)
   Active: active (running) since Mon 2015-10-12 18:31:22 UTC; 19min ago
Comment 1 Marius Cornea 2015-10-13 12:29:28 EDT
neutron-ovs-cleanup calls /usr/lib/ocf/lib/neutron/neutron-ovs-cleanup which looks for /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini which seems not to be present in Liberty. I replaced it with /etc/neutron/plugins/ml2/openvswitch_agent.ini, restarted the cluster and the neutron resource came up.
Comment 2 John Trowbridge 2015-10-13 15:09:27 EDT

*** This bug has been marked as a duplicate of bug 1270325 ***

Note You need to log in before you can comment on or make changes to this bug.