Bug 1271017 - python-docker-py-1.5.0 is available
python-docker-py-1.5.0 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-docker-py (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Tomecek
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks: 1271874
  Show dependency treegraph
 
Reported: 2015-10-12 20:11 EDT by Upstream Release Monitoring
Modified: 2015-12-22 17:06 EST (History)
5 users (show)

See Also:
Fixed In Version: python-docker-py-1.5.0-1.fc23
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 17:06:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2015-10-12 20:11:18 EDT
Latest upstream release: 1.5.0
Current version/release in rawhide: 1.4.0-1.fc24
URL: https://pypi.python.org/pypi/docker-py

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2015-10-12 20:11:33 EDT
Failed to kick off scratch build.

spectool was unable to grab new sources

old source: docker-py-08a4bcd8dc4c207a9c92ca1d825cd0547e7330db.tar.gz
old sha256: a2ee31524d2f42746e6e2f1e9fb2c396719794312292e24bfec2a7b8193acdee

new source: ./docker-py-08a4bcd8dc4c207a9c92ca1d825cd0547e7330db.tar.gz
new sha256: a2ee31524d2f42746e6e2f1e9fb2c396719794312292e24bfec2a7b8193acdee
Comment 2 Upstream Release Monitoring 2015-10-13 04:07:06 EDT
ttomecek's python-docker-py-1.5.0-1.fc24 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=691380
Comment 3 Michael Hampton 2015-10-24 09:18:08 EDT
This was built for rawhide, but not for f23. Can this be built for f23? I have a package depending on it.
Comment 4 Tomas Tomecek 2015-10-26 06:29:43 EDT
(In reply to Michael Hampton from comment #3)
> This was built for rawhide, but not for f23. Can this be built for f23? I
> have a package depending on it.

Will do.
Comment 5 Tomas Tomecek 2015-10-26 06:43:02 EDT
Since docker-py requires pytest-cov >= 2.1.0, Orion, can we update the package in f23?
Comment 6 Orion Poplawski 2015-10-26 13:26:34 EDT
I'm a little concerned about breaking other packages - I needed a patch for StarCluster to use 2.X, but it used some internals.  I show this for deps:

StarCluster-1:0.95.6-4.fc24.src
python-docker-py-0:1.5.0-1.fc24.src
python-gunicorn-0:19.3.0-2.fc23.src
python-jwt-0:1.4.0-1.fc24.src
python-natsort-0:3.5.5-2.fc23.src
python-rackspace-auth-openstack-0:1.3-3.fc24.src
python-structlog-0:15.2.0-1.fc23.src
python-txaio-0:2.0.4-1.fc24.src
python-watchdog-0:0.8.2-2.fc23.src

I'd like to see these built against 2.1.0, perhaps in a copr.
Comment 7 Tomas Tomecek 2015-10-27 05:49:33 EDT
I chose a path of a lazy person. I unpinned pytest-cov requirement and it built just fine:

http://koji.fedoraproject.org/koji/taskinfo?taskID=11596581

Thanks for help Orion.
Comment 8 Upstream Release Monitoring 2015-11-11 04:47:22 EST
rkuska's python-docker-py-1.5.0-2.fc24 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=697782
Comment 9 Tomas Tomecek 2015-12-03 08:22:56 EST
Michael, sorry it took so long, I totally forgot about this. Here's the bodhi update:

https://bodhi.fedoraproject.org/updates/python-docker-py-1.5.0-1.fc23
Comment 10 Fedora Update System 2015-12-03 20:34:59 EST
python-docker-py-1.5.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update python-docker-py'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-3b03817851
Comment 11 Fedora Update System 2015-12-22 17:06:25 EST
python-docker-py-1.5.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.