Bug 1271036 - wubi-jidian can't match chinese char with 'sttt'
wubi-jidian can't match chinese char with 'sttt'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-table-chinese (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 22:05 EDT by Sam Song
Modified: 2015-11-12 21:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 13:54:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Song 2015-10-12 22:05:17 EDT
Description of problem:
Using Wubi-Jidian-86-JiShuang-6.0 ibus addon, I want to input chinese char '覆' with key 'sttt', but no match found.
Switch to pinyin mode using right shift, I input 'fu', the char list doesn't contain '覆' too.

Version-Release number of selected component (if applicable):
$ sudo dnf info ibus-table-chinese-wubi-jidian
Last metadata expiration check performed 10:56:22 ago on Mon Oct 12 22:02:11 2015.
Installed Packages
Name        : ibus-table-chinese-wubi-jidian
Arch        : noarch
Epoch       : 0
Version     : 1.8.2
Release     : 1.fc21
Size        : 5.6 M
Repo        : @System
Summary     : Jidian Wubi 86 input method, JiShuang 6.0
URL         : http://code.google.com/p/ibus/
License     : Freely redistributable without restriction
Description : Jidian Wubi input methods. Current includes:
            : Wubi 86.
$ uname -a
Linux sam-pc-local 4.1.7-200.fc22.x86_64 #1 SMP Mon Sep 14 20:19:24 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:


Steps to Reproduce:
1. switch to Chinese(Wubi-jidian-86-jishuang-6.0) ime
2. input sttt

Actual results:
ime does not match any chinese char

Expected results:
ime match chinese char '覆'

Additional info:
I open /usr/share/ibus-table/tables/wubi-jidian86.db using sqlite3, query the table, there is the record for key sttt.

sqlite> select * from goucima where goucima='sttt';
覆|sttt

But, in the table for pinyin mode, no record for '覆' found.

sqlite> select * from pinyin where pinyin='fu!';
fu!|附|99900000
fu!|肤|96000000
fu!|夫|92500000
fu!|敷|21500000
fu!|傅|19100000
fu!|孚|14100000
fu!|膚|8660000
fu!|溥|3610000
fu!|罘|2840000
fu!|孵|2680000
fu!|麸|2080000
fu!|趺|1130000
fu!|麩|1130000
fu!|伕|790000
fu!|衭|636000
fu!|呋|538000
fu!|姇|470000
fu!|枎|434000
fu!|跗|355000
fu!|泭|292000
fu!|芣|208000
fu!|砆|190000
fu!|粰|172000
fu!|鄜|144000
fu!|枹|99100
fu!|鈇|97900
fu!|稃|91900
fu!|柎|85800
fu!|尃|78200
fu!|鳺|65200
fu!|妋|54600
fu!|怤|50100
fu!|綒|50100
fu!|旉|47200
fu!|玞|43100
fu!|罦|42800
fu!|筟|41900
fu!|邞|38200
fu!|胕|36700
fu!|麬|33900
fu!|抙|30500
fu!|懯|28500
fu!|糐|26600
fu!|荴|25300
fu!|麱|20200
fu!|豧|19600
Comment 1 Mike FABIAN 2015-10-13 05:35:03 EDT
The character is actually there in the pinyin table,
only not as "fu!" (= fu1 = fū) but as "fu$" (= fu4 = fù):

sqlite> select * from pinyin where zi='覆';
fu$|覆|32200000
sqlite>

See:

http://www.zdic.net/z/24/js/8986.htm

which seems to confirm that the pinyin for 覆 is fù.
Comment 2 Mike FABIAN 2015-10-13 06:12:56 EDT
(In reply to Sam Song from comment #0)
> Description of problem:
> Using Wubi-Jidian-86-JiShuang-6.0 ibus addon, I want to input chinese char
> '覆' with key 'sttt', but no match found.
> Switch to pinyin mode using right shift, I input 'fu', the char list doesn't
> contain '覆' too.

I guess your are using the “Simplified Chinese” mode of ibus-table.

ibus-table has 5 Chinese modes:

“Simplified Chinese”:
    means to show simplified Chinese *only*
“Traditional Chinese”:
    means to show traditional Chinese *only*
“Simplified Chinese first”:
    means to show all characters but show simplified Chinese first
“Traditional Chinese first”:
    means to show all characters but show traditional Chinese first
“All Chinese characters”:
    means to show all characters

If I use one of the 4 modes which do not filter out Traditional
Chinese (i.e. any other mode but “Simplified Chinese”), typing the key
'sttt' gives me 覆.  And if Traditional Chinese is not filtered out,
the candidate list also contains 覆 when typing fu (or 'fu$' to reduce
the number of matches).

The file Unihan_Variants.txt from

    http://www.unicode.org/Public/8.0.0/ucd/Unihan.zip

contains:

   2004:U+590D	kTraditionalVariant	U+5FA9 U+8907 U+8986
   7711:U+8986	kSimplifiedVariant	U+590D

(Same in the 7.0.0 version currently used in ibus-table).

That means, according to Unihan_variants.txt, 覆 U+8986 is a character
used in Traditional Chinese only and the unique simplified variant is
复 U+590D. In case the character 覆 U+8986 is used in Simplified
Chinese as well, then this would be a bug in Unihan_variants.txt, in
that case line 7711 in Unihan_variants.txt should be changed to:

   7711:U+8986	kSimplifiedVariant	U+8986 U+590D
Comment 3 Mike FABIAN 2015-10-13 06:22:44 EDT
http://www.zdic.net/z/24/js/8986.htm

seems to tell me that 覆 U+8986 is used *both* in Simplified
Chinese *and* Traditional Chinese.

Is that also your opinion?

If yes, this really looks like a bug in Unihan_variants.txt.

If we are sure that this is the case, I’ll report it at www.unicode.org
(and of course fix it temporarily in ibus-table until the fix is
included in Unihan_variants.txt upstream).
Comment 4 Fedora Update System 2015-10-14 11:48:00 EDT
ibus-table-1.9.7-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-f6cf35bc3d
Comment 5 Fedora Update System 2015-10-14 11:48:36 EDT
ibus-table-1.9.7-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-9bd529f207
Comment 6 Fedora Update System 2015-10-14 11:49:18 EDT
ibus-table-1.9.7-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2f154d7ad0
Comment 7 Fedora Update System 2015-10-14 18:52:38 EDT
ibus-table-1.9.7-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-table'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2f154d7ad0
Comment 8 Fedora Update System 2015-10-15 01:21:07 EDT
ibus-table-1.9.7-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-table'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-f6cf35bc3d
Comment 9 Fedora Update System 2015-10-15 01:52:03 EDT
ibus-table-1.9.7-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-table'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-9bd529f207
Comment 10 Fedora Update System 2015-10-21 03:56:17 EDT
ibus-table-1.9.8-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-9e109344ba
Comment 11 Fedora Update System 2015-10-21 03:57:28 EDT
ibus-table-1.9.8-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-86d0e13945
Comment 12 Fedora Update System 2015-10-21 03:58:45 EDT
ibus-table-1.9.8-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-a6dc32ad5d
Comment 13 Fedora Update System 2015-10-24 08:10:40 EDT
ibus-table-1.9.8-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-table'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-a6dc32ad5d
Comment 14 Fedora Update System 2015-10-26 06:28:01 EDT
ibus-table-1.9.8-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-table'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-9e109344ba
Comment 15 Fedora Update System 2015-10-26 14:30:29 EDT
ibus-table-1.9.8-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-table'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-86d0e13945
Comment 16 Fedora Update System 2015-11-02 13:54:26 EST
ibus-table-1.9.8-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2015-11-12 20:53:28 EST
ibus-table-1.9.8-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2015-11-12 21:52:17 EST
ibus-table-1.9.8-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.