Bug 1271041 - [s390x]Failed to reload virt-who after re-register system
[s390x]Failed to reload virt-who after re-register system
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Radek Novacek
Eko
:
Depends On: 1291737
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 22:41 EDT by Liushihui
Modified: 2016-11-30 19:36 EST (History)
4 users (show)

See Also:
Fixed In Version: virt-who-0.17-1.el7
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:06:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhsm_s390x.log (20.53 KB, text/plain)
2015-10-12 22:42 EDT, Liushihui
no flags Details

  None (edit)
Description Liushihui 2015-10-12 22:41:42 EDT
Description of problem:
Unregister RHEL system, then re-register it to SAM, it can't reload virt-who service.

Version-Release number of selected component (if applicable):
virt-who-0.14-9.el7.noarch
subscription-manager-1.15.9-14.el7.s390x
python-rhsm-1.15.4-5.el7.s390x

How reproducible:
Always

Steps to Reproduce:
1. Register system to SAM, configure virt-who run at libvirt mode, then restart virt-who service. virt-who send h/g mapping to SAM.
[root@ibm-z10-56 ~]# subscription-manager  identity
system identity: d0d8e087-91b6-47cf-a450-079b691d90c5
name: ibm-z10-56.rhts.eng.bos.redhat.com
org name: ACME_Corporation
org ID: ACME_Corporation
[root@ibm-z10-56 ~]# systemctl restart virt-who
[root@ibm-z10-56 ~]# ps -ef|grep virt-who
root     31051     1  4 22:09 ?        00:00:00 /usr/bin/python /usr/share/virt-who/virtwho.py
root     31056 31051  0 22:09 ?        00:00:00 /usr/bin/python /usr/share/virt-who/virtwho.py
root     31060 10633  0 22:09 pts/0    00:00:00 grep --color=auto virt-who

2. Unregister system, then check virt-who's thread, it is correct to show one virt-who thread.
[root@ibm-z10-56 ~]# subscription-manager  unregister
System has been unregistered.
[root@ibm-z10-56 ~]# ps -ef|grep virt-who
root     31051     1  0 22:09 ?        00:00:00 /usr/bin/python /usr/share/virt-who/virtwho.py
root     31070 10633  0 22:10 pts/0    00:00:00 grep --color=auto virt-who

3. Re-register system to SAM, then check virt-who's thread and virt-who's log
[root@ibm-z10-56 ~]# subscription-manager  register --username=admin --password=admin
Registering to: samserv.redhat.com:443/sam/api
The system has been registered with ID: 9748fd28-2e89-4c83-80ac-46a99a991248 
[root@ibm-z10-56 ~]# ps -ef|grep virt-who
root     31051     1  0 22:09 ?        00:00:00 /usr/bin/python /usr/share/virt-who/virtwho.py
[root@ibm-z10-56 ~]# ps -ef|grep virt-who
root     31051     1  0 22:09 ?        00:00:00 /usr/bin/python /usr/share/virt-who/virtwho.py
[root@ibm-z10-56 ~]# systemctl status virt-who
● virt-who.service - Daemon for reporting virtual guest IDs to subscription-manager
   Loaded: loaded (/usr/lib/systemd/system/virt-who.service; disabled; vendor preset: disabled)
   Active: active (running) since Mon 2015-10-12 22:09:35 EDT; 9min ago
 Main PID: 31051 (python)
   CGroup: /system.slice/virt-who.service
           └─31051 /usr/bin/python /usr/share/virt-who/virtwho.py

Oct 12 22:09:59 ibm-z10-56.rhts.eng.bos.redhat.com virt-who[31051]: self._sendGuestList(report)
Oct 12 22:09:59 ibm-z10-56.rhts.eng.bos.redhat.com virt-who[31051]: File "/usr/share/virt-who/virtwho.py", line 196, in _sendGuestList
Oct 12 22:09:59 ibm-z10-56.rhts.eng.bos.redhat.com virt-who[31051]: manager.sendVirtGuests(report.guests)
Oct 12 22:09:59 ibm-z10-56.rhts.eng.bos.redhat.com virt-who[31051]: File "/usr/share/virt-who/manager/subscriptionmanager/subscripti...uests
Oct 12 22:09:59 ibm-z10-56.rhts.eng.bos.redhat.com virt-who[31051]: self._connect()
Oct 12 22:09:59 ibm-z10-56.rhts.eng.bos.redhat.com virt-who[31051]: File "/usr/share/virt-who/manager/subscriptionmanager/subscripti...nnect
Oct 12 22:09:59 ibm-z10-56.rhts.eng.bos.redhat.com virt-who[31051]: "Unable to read certificate, system is not registered or you are...oot")
Oct 12 22:09:59 ibm-z10-56.rhts.eng.bos.redhat.com virt-who[31051]: SubscriptionManagerUnregisteredError: Unable to read certificate... root
Oct 12 22:10:37 ibm-z10-56.rhts.eng.bos.redhat.com python[31051]: virt-who reload
Oct 12 22:10:37 ibm-z10-56.rhts.eng.bos.redhat.com virt-who[31051]: 2015-10-12 22:10:37,503 WARNING: virt-who reload
Hint: Some lines were ellipsized, use -l to show in full.

Actual results:
1 Although system has registered to SAM, virt-who failed to send h/g mapping to server. please see the log in attachment.
2 Failed to re-load virt-who service , it only show one virt-who thread after re-register system.

Expected results:
After system re-register to SAM, virt-who should send h/g mapping to server successfully. Meanwhile, virt-who should re-load successfully, it should show two virt-who threads.

Additional info:
It hasn't this problem on x86_64 and ppc64
Comment 1 Liushihui 2015-10-12 22:42 EDT
Created attachment 1082209 [details]
rhsm_s390x.log
Comment 2 Radek Novacek 2015-10-13 09:15:45 EDT
Should be fixed in the upstream repository.
Comment 4 Radek Novacek 2016-05-17 09:03:30 EDT
Fixed in virt-who-0.17-1.el7.
Comment 6 Liushihui 2016-06-02 22:40:41 EDT
Verified it on virt-who-0.17-2.el7.noarch since virt-who work normally after re-register to Satellite/SAM.
Comment 9 errata-xmlrpc 2016-11-04 01:06:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2387.html

Note You need to log in before you can comment on or make changes to this bug.