Bug 127105 - RHEL 2.1: x445 Legacy USB support workaround needed
RHEL 2.1: x445 Legacy USB support workaround needed
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jason Baron
Brian Brock
Depends On: 126984
Blocks: 143573
  Show dependency treegraph
Reported: 2004-07-01 17:48 EDT by john stultz
Modified: 2013-03-06 00:57 EST (History)
7 users (show)

See Also:
Fixed In Version: RHSA-2005-529
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-25 09:28:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
x440-usb-legacy-fix_A0 (3.12 KB, patch)
2004-07-13 21:47 EDT, john stultz
no flags Details | Diff
The patch backported from RHEL3 (5.29 KB, patch)
2004-09-29 03:00 EDT, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description john stultz 2004-07-01 17:48:05 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, 
like Gecko) 
Description of problem: 
This is the RHEL 2.1 AS version of bug #126984 
Apparently there is an issue w/ the IBM x445's BIOS's USB Legacy 
support. Due to the delay in issuing SMI's across the IOAPICs, its 
possible for I/O to ports 60/64 to cause register corruption.  
The solution we're looking at is to disable BIOS's USB Legacy SMI 
early on boot (via pci quirks).  
This is the same solution proposed to resolve issues w/ laptop issues 
related to touchpads and external mice. 
Version-Release number of selected component (if applicable): 
How reproducible: 
Steps to Reproduce: 
1. Enable USB Legacy support on x445 
2. Disconnect PS2 keyboard, reconnect USB keyboard 
3. Boot system 
Actual Results:  Random kernel panics or hangs. Sometimes nothing at 
Expected Results:  No problems. 
Additional info:
Comment 1 john stultz 2004-07-01 17:53:08 EDT
I'm working on the patch for the 2.4.9-summit kernel. After we have 
tested it here I'll post it. 
Comment 2 john stultz 2004-07-13 21:47:20 EDT
Created attachment 101882 [details]

Here is the current fix against RHAS 2.1. I've run this by GregKH for sanity
checking and he said it looked fine. Currently we are still testing this patch,
but I figured I should attach it so it could be reviewed.
Comment 3 john stultz 2004-07-19 17:45:04 EDT
The patch (attachment #101882 [details]) has been tested and is ready for 
inclusion. I'll be sending out patches against mainline to lkml later 
Comment 4 Bastien Nocera 2004-07-22 06:27:45 EDT
Waiting on code review happening in bug #126984, added to the RHEL 2.1
U6 blockers candidates list
Comment 8 john stultz 2004-09-24 18:37:41 EDT
Anything else need to be done for this now that the RHEL3 version has 
been included?  
Comment 11 Pete Zaitcev 2004-09-28 21:40:55 EDT
We have a slightly different version for RHEL3, I suggest we use
that one instead of the one currently attached (in comment #2).
Comment 12 Pete Zaitcev 2004-09-29 03:00:43 EDT
Created attachment 104490 [details]
The patch backported from RHEL3

John's old patch worked just fine, I suppose. I completely forgot
that the old .spec applied it to Summit kernels only on 2.4.9 series,
so there was zero risk of regressions on other platforms.
I'm adding an RHEL3 based version in case Jason prefers
Comment 13 Jason Baron 2004-09-29 11:54:00 EDT
John, mind testing Pete's patch?
Comment 14 Jason Baron 2004-10-14 13:54:32 EDT
Pete's patch is in the U6 beta
Comment 15 john stultz 2004-10-25 21:31:21 EDT
I don't see the fix in kernel-source-2.4.9-e.51, am I missing 
Comment 16 Jason Baron 2004-10-26 17:05:43 EDT
Unfortunately rhel2.1 doesn't have one source code base (rhel3 forward
does, however). The patch is only being applied to the summit kernel.
The patch is linux-2.4.9e12_get_irq_list.patch in the .src.rpm.
Hopefully that's not too confusing.
Comment 17 john stultz 2004-10-28 13:47:09 EDT
Ah, my mistake. Sorry I missed it. I've run almost 2 full days of 
rebooting on the system, and the original issue has not cropped up, 
so I'd say this is resolved. 
Comment 18 angus 2005-04-12 07:26:42 EDT
Now, linux-2.4.9e12_get_irq_list.patch is also usefull for IBM x336 & x346
machine (which have USB2 controller).

So applying this patch to smp, up and enterprise kernel is required to not
having kernel panic on these machines
Comment 22 Pete Zaitcev 2005-04-19 14:05:11 EDT
Woops, I made a mistake, the patch from comment #12 is ok.
I am comfortable with that one (but not with Wendy's version).

It sits in linux-2.4.9e12_get_irq_list.patch in 2.4.9-e.61,
mixed with other Summit bits, so I guess you'll need to pull
it out with a text editor.

Now, perhaps what Wendy tried to do was to pull out the
part which patches drivers/pci/quirks.c but leave the part
which patches arch/i386/kernel/mpparse.c. That would be
the right thing to do, I suppose.
Comment 23 Jason Baron 2005-04-26 13:33:57 EDT
Pete, don't you mean the opposite? Leave the quirk.c bits, but remove the
mmparse.c bits?

Comment 24 Pete Zaitcev 2005-04-28 16:09:17 EDT
The current situation in Pensacola is that both quirk.c and mpparse.c
parts are applied on Summit only (from linux-2.4.9e12_get_irq_list.patch).
The proposal is to remove quirk.c from there and move it to some place
where it would apply to all architectures, at prep time, not build time.
The mpparse.c part is left alone then.

The last paragraph speculated why Wendy did not post the mpparse.c part
for the review (because it stays where it is).
Comment 34 Red Hat Bugzilla 2005-08-25 09:28:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.