Bug 127110 - maximum channel length needs to be increased
Summary: maximum channel length needs to be increased
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xchat   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Reed
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-01 22:30 UTC by Colin Charles
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-02 21:54:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new chanlen limit patch (384 bytes, patch)
2004-07-01 22:31 UTC, Colin Charles
no flags Details | Diff
new spec file for rebuilding (17.01 KB, text/plain)
2004-07-01 22:32 UTC, Colin Charles
no flags Details

Description Colin Charles 2004-07-01 22:30:21 UTC
Description of problem:
While trying to get on an IRC server and automatically have it join
channels for me, I noticed that the last few channels in the
list/string wasn't being joined properly. There was no indication as
to why this was the case, so I ended up digging into source :P

Version-Release number of selected component (if applicable):
xchat-2.0.9-1

How reproducible:
Always

Steps to Reproduce:
1. Start X-Chat
2. X-Chat -> Server List
3. In the Join Channels: dialog, enter a list of channels
(#channelname,#channel2,#channel3) and so on
4. Make it exceed 202 characters - there is no visual feedback that
the string limit is 202 characters, it allows you to type till more
5. So I go on typing, and get to 209 characters
6. When it connects to the server, it just cuts off everything after
202 characters. And there is no error message as to why this is done.
So joing a channel like #fedora-devel, can become #fed and thats it
  
Actual results:
Last channel in the 202 limit gets its string cut off (like
#fedora-devel becomes #fed where, the 'd' is char #202). Channels
afterward just don't show as being automatically joined, and now I
have to manually join them

Expected results:
It joins all my channels in the Join Channel: list

Additional info:
Seems src/common/xchat.h has a hard defined limit at 202 - who decided
on this arbritrary number ?

Attached is a patch to rebuild it, at a limit of 300. Why did I choose
300? Because on a standard 1024x768 display, that seems like a good
average. 

Otherwise, there must be a visible limit, and the user must get
feedback that the limit exists while entering information into the
Join Channels: dialog

Comment 1 Colin Charles 2004-07-01 22:31:40 UTC
Created attachment 101576 [details]
new chanlen limit patch

Comment 2 Colin Charles 2004-07-01 22:32:25 UTC
Created attachment 101577 [details]
new spec file for rebuilding

Comment 3 Mike A. Harris 2004-08-02 05:51:01 UTC
This should probably be submitted to the xchat author directly,
in case there is a specific reason the code has this limit.

Comment 4 Daniel Reed 2004-08-02 21:54:25 UTC
This has been migrated upstream:
http://sourceforge.net/tracker/index.php?func=detail&atid=100239&aid=1002292&group_id=239


Note You need to log in before you can comment on or make changes to this bug.