Bug 127112 - Can't make accented words with english keyboard
Can't make accented words with english keyboard
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-01 19:13 EDT by Santiago Erquicia
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-06 17:31:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shows epiphany before pressing the button (24.26 KB, image/png)
2004-07-01 19:19 EDT, Santiago Erquicia
no flags Details
Shows epiphany after pressing the button (17.36 KB, image/png)
2004-07-01 19:20 EDT, Santiago Erquicia
no flags Details

  None (edit)
Description Santiago Erquicia 2004-07-01 19:13:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Epiphany/1.2.4

Description of problem:
Since I installed Fedora Core 2 (clean install), I cannot make my
english keyboard create accented words using the Keyboard Switcher to
turn the layout either to Latin American nor Spanish.

The other day I tested Debian unstable with gnome 2.6 and the same
thing happened.

I tried with and without the deadkeys set.

Version-Release number of selected component (if applicable):
gnome-panel-2.6.0-9

How reproducible:
Always

Steps to Reproduce:
1.Use an english keyboard
2.Add a spanish or latin american layout in gnome
3.Try to accent a letter
    

Actual Results:  When the deadkey is pressed, nothing happens which it
is fine.  If you press it twice, it doesn't show the deadkey symbol. 
If you press a vowel, it doesn't show it accented.

Expected Results:  The vowel is accented

Additional info:

I have no problem to create the � and � letters so the layout is changed.

UPDATE:  When I was entering the bug, the previous sentence showed the
letter that is the n with ~ on top of it without any problem.  When I
pressed the "open bugzilla entry form" button, it showed everything I
typed and now those letters are showed as question mark symbols.  I
will attach the screenshots.

I saw in another bug that you asked about the $LANG variable.   This
is the result:
echo $LANG
en_US.UTF-8
Comment 1 Santiago Erquicia 2004-07-01 19:19:32 EDT
Created attachment 101579 [details]
Shows epiphany before pressing the button
Comment 2 Santiago Erquicia 2004-07-01 19:20:04 EDT
Created attachment 101580 [details]
Shows epiphany after pressing the button
Comment 3 Santiago Erquicia 2004-07-06 09:25:29 EDT
Using the following command I can get the accented words

[pampa@localhost pampa]$ setxkbmap -v -layout la
Warning! Multiple definitions of keyboard layout
         Using command line, ignoring X server
Trying to build keymap using the following components:
keycodes:   xfree86+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc/pc(pc105)+pc/la+group(shift_toggle)
geometry:   pc(pc105)

The panel applet even shows LAm as the keyboard layout under GNOME.
Comment 4 Mark McLoughlin 2004-08-11 04:38:18 EDT
Could you try updating to gnome-applets-2.6.2.1-1 and see if that
fixes your problem?
Comment 5 Santiago Erquicia 2004-08-11 08:15:47 EDT
I already have this version installed and nothing changed.

The other day I installed FC2 in my brother's computer and he selected
spanish as his layout during the install.  He has everything working
perfectly.
Comment 6 Mark McLoughlin 2004-08-18 07:19:02 EDT
Okay, this looks very much like an XKB issue - moving to xorg
Comment 7 Mike A. Harris 2004-08-21 09:51:18 EDT
Please report this problem to X.Org bugzilla located at:

http://bugs.freedesktop.org in the "xorg" component.

Once the issue is reported upstream, please paste the X.Org bug
report URL here, and Red Hat will track the issue in X.Org bugzilla.
If a fix becomes available, we will review it for consideration in
a future xorg-x11 update.

Thanks in advance.
Comment 8 Santiago Erquicia 2004-08-23 12:10:14 EDT
I don't think this is an xorg problem.  A few months ago I tried
Debian unstable and when I upgraded to gnome 2.6 I had the same
problem.  Debian only has xfree86 4.3 so I think that the problem is
within gnome.

When I did that upgrade, I was using gnome 2.4 with the previous
layout applet and everything was running smoothly.

Do you think that I still need to file this bug under xorg?
Comment 9 Mark McLoughlin 2004-08-23 12:39:47 EDT
gnome 2.4 layout switcher used xmodmap, 2.6 layout switcher uses XKB
and the bug looks like its an XKB one
Comment 10 Santiago Erquicia 2004-08-23 13:32:40 EDT
I submitted the bug upstream.  This is the link:

https://freedesktop.org/bugzilla/show_bug.cgi?id=1166
Comment 11 Santiago Erquicia 2004-09-03 11:18:20 EDT
I just saw on a rawhide update of xorg that now it doesn't support the
kayboard driver but instead uses the kbd.  I now this is for FC3 but I
want to know if that also applies to FC2.

This is my xorg.conf right now:

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name
of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "keyboard"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Toshiba TOS5082"
	DisplaySize  310	230
	HorizSync    31.0 - 48.0
	VertRefresh  50.0 - 70.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "trident"
	VendorName  "Videocard vendor"
	BoardName   "Trident CyberBlade (generic)"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
Comment 12 Kristian Høgsberg 2004-09-15 15:50:28 EDT
I couldn't reproduce your problem using the current rawhide X.org and
gnome packages. I tried adding a Spanish and a Latin American layout,
and I'm able to enter accented characters with both layouts: áäàâ.

You mention that when you change the layout using setxkbmap "the panel
applet even shows LAm".  Is this not otherwise the case?

Could you try running, and type the accented character into the xev
window and add the events logged when you press the keys?

The keyboard driver update should not be related to this issue.
Comment 13 Santiago Erquicia 2004-10-04 12:00:54 EDT
OK, i found the problem.

Trying to figure out where it was, I execute the following command:

santiago@pampa ~ $ setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "xfree86+aliases(qwerty)"       };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include
"pc/pc(pc105)+pc/us+pc/la(Sundeadkeys):2+group(shift_toggle)"   };
        xkb_geometry  { include "pc(pc105)"     };
};

As you can see, I had the la(Sundeadkeys) layout as an option.

The way I was fixing this temporarily was by running this command:

setxkbmap -v -layout la

I realized that in this command the layout was different.

I went to the GNOME keyboard preferences and selected the Latin
American layout,
that means the father in the tree of the other options such as
Sundeadkeys and
Eliminate Sundeadkeys.  I never selected this option because I thought
it was
just a grouping and not an actual option.  That solved the problem.

Note You need to log in before you can comment on or make changes to this bug.