Bug 1271129 - Setting email_reply_address is not used without restart of Foreman
Setting email_reply_address is not used without restart of Foreman
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Email (Show other bugs)
6.1.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Beta
: --
Assigned To: Stephen Benjamin
Og Maciel
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1122832
  Show dependency treegraph
 
Reported: 2015-10-13 04:33 EDT by Peter Vreman
Modified: 2016-07-27 04:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 04:57:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12155 None None None 2016-04-22 12:21 EDT

  None (edit)
Description Peter Vreman 2015-10-13 04:33:18 EDT
Description of problem:
Changing the setting email_reply_address the new value is not used until Foreman is restarted

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Change the email_reply_address setting to foobar
2. Trigger a mail sending
3.

Actual results:
The from address is still using the original from address and not the updated foobar

Expected results:
Mail from address is changed to foobar

Additional info:
Comment 1 Bryan Kearney 2015-10-13 13:54:28 EDT
Created redmine issue http://projects.theforeman.org/issues/12155 from this bug
Comment 3 Bryan Kearney 2015-10-15 10:03:58 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/12155 has been closed
-------------
Anonymous
Applied in changeset commit:4fdf2f97ad63898dee899f8fe77dd9e47221ffca.
Comment 5 Bryan Kearney 2015-11-13 14:02:34 EST
Upstream bug assigned to stbenjam@redhat.com
Comment 7 Og Maciel 2016-03-22 15:39:30 EDT
Verified this issue using Satellite 6.2.0 SNAP 4.0 build on a RHEL 7.2 x86_64 system.

Steps:

* Configure your Satellite system to use email notifications by updating your /etc/foreman/email.yaml file and providing valid values for all required attributes
* Restart the entire stack by running katello-service restart
* Once the system is back online, use the web ui and update your user's configuration (click on your user name on the upper right corner of the UI after you've logged in and click the My Account link) to include a valid email address
  NOTE: using gmail accounts most likely won't work, so use another email
* Then, under the Email Preferences form (still in the My Account page), enable all types of email notifications available
* Create a new custom YUM repository (use https://omaciel.fedorapeople.org/fakerepo02/ for example) and synchronize it


You should receive an email stating that the new repo was successfully synced.

* Update the email address to another valid email address and repeat the steps of creating a new repo (use https://omaciel.fedorapeople.org/fakerepo01/ this time) and syncing it.
Comment 10 errata-xmlrpc 2016-07-27 04:57:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.