Bug 1271150 - libglusterfs : glusterd was not restarting after setting key=value length beyond PATH_MAX (4096) character
libglusterfs : glusterd was not restarting after setting key=value length bey...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libglusterfsclient (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Satish Mohan
: ZStream
Depends On:
Blocks: 1319649
  Show dependency treegraph
 
Reported: 2015-10-13 05:10 EDT by Gaurav Kumar Garg
Modified: 2016-06-16 09:39 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1269203
: 1319649 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:39:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-10-13 05:25:28 EDT
REVIEW: http://review.gluster.org/12346 (libglusterfs: read volfile based on the volfile size) posted (#1) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 2 Vijay Bellur 2015-10-13 10:15:29 EDT
REVIEW: http://review.gluster.org/12346 (libglusterfs: read volfile based on the volfile size) posted (#2) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 3 Vijay Bellur 2015-10-13 10:48:54 EDT
REVIEW: http://review.gluster.org/12346 (libglusterfs: read volume configuration file based on the file size) posted (#3) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 4 Vijay Bellur 2015-10-13 10:53:32 EDT
REVIEW: http://review.gluster.org/12346 (libglusterfs: restarting glusterd will fail while parsing volume info file.) posted (#4) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 5 Vijay Bellur 2015-10-13 11:59:01 EDT
REVIEW: http://review.gluster.org/12346 (libglusterfs: pass buffer size to gf_store_read_and_tokenize function) posted (#5) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 7 Vijay Bellur 2015-10-14 04:34:00 EDT
REVIEW: http://review.gluster.org/12346 (libglusterfs: pass buffer size to gf_store_read_and_tokenize function) posted (#6) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 8 Vijay Bellur 2015-10-14 16:42:34 EDT
COMMIT: http://review.gluster.org/12346 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 816ca94f5dd49f34f395caf501de3c71f0ba113d
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Tue Oct 13 14:40:55 2015 +0530

    libglusterfs: pass buffer size to gf_store_read_and_tokenize function
    
    Previously if user set an option where length of key=value goes beyond
    PATH_MAX (4096) character then tokenzing the option at the time of
    reading configuration file will fail.
    This is because of the we was having restraction in fgets to read maximum
    of PATH_MAX (4096) length of character.
    Consequence of this is when user try to restart glusterd, after setting
    key=value length beyond PATH_MAX (4096) character, glusterd will not restart.
    
    With this fix instead of PATH_MAX, consumer of gf_store_read_and_tokenize
    function will decide the size of the buffer length.
    
    Change-Id: I655a8ce982effdfff8f3e785ea31f543dbe39301
    BUG: 1271150
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/12346
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Nekkunti <anekkunt@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 11 Niels de Vos 2016-06-16 09:39:57 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.