Bug 1271157 - Host CPU seen as Westmere instead of Haswell
Host CPU seen as Westmere instead of Haswell
Status: CLOSED DUPLICATE of bug 870071
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 05:28 EDT by jean-christophe manciot
Modified: 2015-10-13 11:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 11:49:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jean-christophe manciot 2015-10-13 05:28:29 EDT
Description of problem:
----------------------
Virt-manager sees my host CPU as <model>Westmere</model>, although it is an Intel i7 4700-MQ. It is a Haswell chipset: http://www.notebookcheck.net/Review-Intel-Haswell-Processors.93189.0.html

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
I'm not sure which component is responsible for querying the CPU model and qemu:///system capabilities.
virt-manager: last github sources
libosinfo: 0.2.12
libvirt-bin: 1.2.20
qemu: 2.4.0

This issue may have some consequences regarding the performances of the VMs since not all the CPU capabilities are used.

How reproducible:
-----------------
On a i7 4700MQ system:
virt-manager --debug
...
qemu:///system capabilities:
<capabilities>

  <host>
    <uuid>00000000-0000-0000-0000-8c89a50e4e89</uuid>
    <cpu>
      <arch>x86_64</arch>
      <model>Westmere</model>
      <vendor>Intel</vendor>
      <topology sockets="1" cores="4" threads="2"/>
      <feature name="invtsc"/>
      <feature name="invpcid"/>
      <feature name="erms"/>
      <feature name="bmi2"/>
      <feature name="smep"/>
      <feature name="avx2"/>
      <feature name="bmi1"/>
      <feature name="fsgsbase"/>
      <feature name="abm"/>
      <feature name="rdtscp"/>
      <feature name="pdpe1gb"/>
      <feature name="rdrand"/>
      <feature name="f16c"/>
      <feature name="avx"/>
      <feature name="osxsave"/>
      <feature name="xsave"/>
      <feature name="tsc-deadline"/>
      <feature name="movbe"/>
      <feature name="pcid"/>
      <feature name="pdcm"/>
      <feature name="xtpr"/>
      <feature name="fma"/>
      <feature name="tm2"/>
      <feature name="est"/>
      <feature name="vmx"/>
      <feature name="ds_cpl"/>
      <feature name="monitor"/>
      <feature name="dtes64"/>
      <feature name="pclmuldq"/>
      <feature name="pbe"/>
      <feature name="tm"/>
      <feature name="ht"/>
      <feature name="ss"/>
      <feature name="acpi"/>
      <feature name="ds"/>
      <feature name="vme"/>
      <pages unit="KiB" size="4"/>
      <pages unit="KiB" size="2048"/>
    </cpu>
    <power_management>
      <suspend_mem/>
      <suspend_disk/>
      <suspend_hybrid/>
    </power_management>
    <migration_features>
      <live/>
      <uri_transports>
        <uri_transport>tcp</uri_transport>
        <uri_transport>rdma</uri_transport>
      </uri_transports>
    </migration_features>
    <topology>
      <cells num="1">
        <cell id="0">
          <memory unit="KiB">16351008</memory>
          <cpus num="8">
            <cpu id="0" socket_id="0" core_id="0" siblings="0"/>
            <cpu id="1" socket_id="0" core_id="0" siblings="1"/>
            <cpu id="2" socket_id="0" core_id="1" siblings="2"/>
            <cpu id="3" socket_id="0" core_id="1" siblings="3"/>
            <cpu id="4" socket_id="0" core_id="2" siblings="4"/>
            <cpu id="5" socket_id="0" core_id="2" siblings="5"/>
            <cpu id="6" socket_id="0" core_id="3" siblings="6"/>
            <cpu id="7" socket_id="0" core_id="3" siblings="7"/>
          </cpus>
        </cell>
      </cells>
    </topology>
    <secmodel>
      <model>none</model>
      <doi>0</doi>
    </secmodel>
    <secmodel>
      <model>dac</model>
      <doi>0</doi>
      <baselabel type="kvm">+0:+0</baselabel>
      <baselabel type="qemu">+0:+0</baselabel>
    </secmodel>
  </host>

Additional info:
---------------
Ubuntu Server 15.04
Comment 1 Cole Robinson 2015-10-13 11:49:03 EDT
This is a long known problem with libvirt's CPU detection

*** This bug has been marked as a duplicate of bug 870071 ***

Note You need to log in before you can comment on or make changes to this bug.