Bug 1271159 - cannot load some policy modules which contain SELinux admin interfaces
Summary: cannot load some policy modules which contain SELinux admin interfaces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-13 09:37 UTC by Milos Malik
Modified: 2016-11-04 02:23 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-81.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 02:23:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2283 0 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2016-11-03 13:36:25 UTC

Description Milos Malik 2015-10-13 09:37:50 UTC
Description of problem:
 * there are typo errors or undefined types in some SELinux admin interfaces

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.13.1-58.el7.noarch
selinux-policy-mls-3.13.1-58.el7.noarch
selinux-policy-devel-3.13.1-58.el7.noarch
selinux-policy-minimum-3.13.1-58.el7.noarch
selinux-policy-doc-3.13.1-58.el7.noarch
selinux-policy-3.13.1-58.el7.noarch
selinux-policy-sandbox-3.13.1-58.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. get a RHEL-7.2 machine with active targeted policy
2. write a policy module which uses one of following admin interfaces
3. compile the policy module
4. load it

Actual results (dnssectrigger_admin interface)
+ /usr/sbin/semodule -i confined_admin.pp 
libsepol.print_missing_requirements: confined_admin's global requirements were not met: type/attribute dkim_milter_initrc_exec_t (No such file or directory).
libsemanage.semanage_link_sandbox: Link packages failed (No such file or directory).
/usr/sbin/semodule:  Failed!

Actual results (dkim_admin interface)
+ /usr/sbin/semodule -i confined_admin.pp
libsepol.print_missing_requirements: confined_admin's global requirements were not met: type/attribute dnssec_triggerd_var_run_t (No such file or directory).
libsemanage.semanage_link_sandbox: Link packages failed (No such file or directory).
/usr/sbin/semodule:  Failed!

Expected results:
 * policy modules which contain SELinux admin interfaces can be loaded

Comment 1 Milos Malik 2015-10-16 15:15:41 UTC
Actual results (samba_admin)
+ /usr/sbin/semodule -i confined_admin.pp
libsepol.print_missing_requirements: confined_admin's global requirements were not met: type/attribute smbd_spool_t (No such file or directory).
libsemanage.semanage_link_sandbox: Link packages failed (No such file or directory).
/usr/sbin/semodule:  Failed!

Actual results (rpm_admin)
+ /usr/sbin/semodule -i confined_admin.pp
libsepol.print_missing_requirements: confined_admin's global requirements were not met: type/attribute rpm_initrc_exec_t (No such file or directory).
libsemanage.semanage_link_sandbox: Link packages failed (No such file or directory).
/usr/sbin/semodule:  Failed!

Comment 6 errata-xmlrpc 2016-11-04 02:23:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html


Note You need to log in before you can comment on or make changes to this bug.