Bug 1271200 - Overcloud images contain Kilo repos
Overcloud images contain Kilo repos
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: instack-undercloud (Show other bugs)
Liberty
Unspecified Unspecified
unspecified Severity high
: ---
: Liberty
Assigned To: John Trowbridge
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 07:23 EDT by Marius Cornea
Modified: 2017-06-18 02:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-tripleoclient-0.0.11-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-18 02:23:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-10-13 07:23:24 EDT
Description of problem:
The overcloud images contain Kilo repositories. 

Version-Release number of selected component (if applicable):
openstack-tripleo-image-elements-0.9.7-dev30.el7.centos.noarch
openstack-tripleo-puppet-elements-0.0.2-dev13.el7.centos.noarch
python-tripleoclient-0.0.11-dev64.el7.centos.noarch
openstack-tripleo-0.0.1-dev1769.el7.centos.noarch
openstack-tripleo-heat-templates-0.8.7-dev277.el7.centos.noarch
tripleo-common-0.0.1-dev20.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Following the Liberty docs to build images:
https://repos.fedorapeople.org/repos/openstack-m/rdo-manager-docs/liberty/basic_deployment/basic_deployment_cli.html
2. Deploy overcloud 
3. Check the repositories on the overcloud nodes 

Actual results:
repo name                                     
CentOS-7 - Base                               
CentOS Cloud RDO                              
Extra Packages for Enterprise Linux 7 - x86_64
CentOS-7 - Extras                             
OpenStack Kilo Repository                     
CentOS-7 - Updates                            

Expected results:
There are no Kilo repos enabled.

Additional info:
[root@overcloud-controller-1 ~]# cat /etc/yum.repos.d/rdo*
[openstack-kilo]
name=OpenStack Kilo Repository
baseurl=http://repos.fedorapeople.org/repos/openstack/openstack-kilo/el7/
skip_if_unavailable=0
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-RDO-kilo
[openstack-kilo-testing]
name=OpenStack Kilo Testing
baseurl=http://repos.fedorapeople.org/repos/openstack/openstack-kilo/testing/el7/
skip_if_unavailable=0
gpgcheck=0
enabled=0
Comment 1 John Trowbridge 2015-10-13 08:22:44 EDT
There is not a liberty-release rpm yet, so this will be partially solved after GA. However, this shows a flaw in our method of using delorean to build the overcloud images. Currently the delorean-repo element in instack-undercloud is broken, so we use DIB_YUM_REPO_CONF to get delorean packages during the image build. This does not install the repos into the overcloud images, but just uses them to get packages during the image build.

Having a kilo release repo with delorean repos with a higher priority would not be an issue since the kilo packages would never get pulled. As such, I think we should use this bug to track fixing the delorean-repo element.
Comment 2 John Trowbridge 2015-10-20 19:59:45 EDT
This is fixed in the liberty-testing repo
http://buildlogs.centos.org/centos/7/cloud/x86_64/openstack-liberty/

with python-tripleoclient-0.0.11-3

However, I am going to leave it assigned until the fix is also in delorean.

In order to use the release repo when building images it is now needed to:
`export RDO_RELEASE=<release>`

so for liberty:
`export RDO_RELEASE='liberty'`
Comment 4 Christopher Brown 2017-06-17 13:22:34 EDT
This was fixed so can be closed.

Note You need to log in before you can comment on or make changes to this bug.