Bug 1271210 - SQL command not properly ended on Oracle11
SQL command not properly ended on Oracle11
Status: CLOSED WORKSFORME
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Maciej Swiderski
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 07:46 EDT by Ivo Bek
Modified: 2015-10-21 09:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 09:28:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server log (1.58 MB, text/plain)
2015-10-13 07:46 EDT, Ivo Bek
no flags Details

  None (edit)
Description Ivo Bek 2015-10-13 07:46:34 EDT
Created attachment 1082356 [details]
server log

Description of problem:

Business Central is not deployed due to SQL exceptions (see the attached server.log) after I create schema based on:

https://github.com/droolsjbpm/jbpm/blob/master/jbpm-installer/db/ddl-scripts/oracle/oracle-jbpm-schema.sql

Business Central is configured to use org.jbpm.persistence.jpa.hibernate.DisabledFollowOnLockOracle10gDialect

Another alternative is to start Business Central with empty database and then run process instances with human task simultaneously in 16 threads - the same exceptions occur when the clients try to complete their tasks. However, the easiest way to reproduce the problem is described above. I believe that the processes then fail because of the missing indexes....
Comment 1 Maciej Swiderski 2015-10-15 13:17:38 EDT
since JMS based executor has been introduced the org.jbpm.persistence.jpa.hibernate.DisabledFollowOnLockOracle10gDialect should not be used as it was considered just a workaround when many executor threads were configured. Since this is not needed any more standard oracle dialect should be used.

Can you please try to run it with standard Oracle dialect instead.
Comment 2 Maciej Swiderski 2015-10-16 10:40:40 EDT
After further investigation of the attached log the problem is that kie server is deployed and apparently ExampleDS is Oracle data source while kie server has not been configured for Oracle and still uses H2 dialect and thus sql not properly ended error.

Make sure to configure data source and dialed for Kie Server using system properties:
-Dorg.kie.server.persistence.dialect=org.hibernate.dialect.Oracle10gDialect 
-Dorg.kie.server.persistence.ds=java:jboss/datasources/oracleDS

Please also note that it is recommended to use different data sources (db schemas) for business central and kie server to avoid any unexpected behavior.
Comment 3 Ivo Bek 2015-10-21 09:28:20 EDT
OK, I confirm that the recommended changes to KIE server helped. Thank you, Maciej. ... so closing the issue.

Note You need to log in before you can comment on or make changes to this bug.