Bug 1271226 - Dynamic VDB generation - Default value for string column problem (DDL)
Dynamic VDB generation - Default value for string column problem (DDL)
Status: CLOSED NOTABUG
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.2.0
Unspecified Mac OS
unspecified Severity medium
: ---
: ---
Assigned To: Barry LaFond
Matus Makovy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 08:18 EDT by Matus Makovy
Modified: 2016-09-13 08:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 08:27:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-2687 Major Closed Dynamic VDB generation - Default value for string column problem (DDL) 2016-09-13 08:04 EDT

  None (edit)
Description Matus Makovy 2015-10-13 08:18:19 EDT
I have a model with table that has String column with default value "Stock".
DDL generated by TD for dynamic VDB looks like this:


...
TYPE string(15) DEFAULT ('Stock')  OPTIONS(NAMEINSOURCE '"TYPE"', NATIVE_TYPE 'VARCHAR2', UPDATABLE 'FALSE'),
...


DEFAULT ('Stock') is not correct, it should be: DEFAULT '("Stock")'
Comment 1 Van Halbert 2015-10-13 08:56:40 EDT
I don't think DEFAULT '("Stock")' is correct, even though it may work.  Its not consistent with defining other attributes.  Now, if you would have said something like:   DEFAULT ('"Stock"')  , then possibly.
Comment 2 Barry LaFond 2015-12-07 08:27:40 EST
Using only JIRA now.  Marking as closed
Comment 3 JBoss JIRA Server 2016-08-19 13:20:40 EDT
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-2687 to Resolved
Comment 4 JBoss JIRA Server 2016-09-13 08:04:54 EDT
Matus Makovy <mmakovy@redhat.com> updated the status of jira TEIIDDES-2687 to Closed

Note You need to log in before you can comment on or make changes to this bug.