Bug 127123 - recompile the kernel
recompile the kernel
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-07-02 05:14 EDT by ilja lunev
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-07-02 09:27:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description ilja lunev 2004-07-02 05:14:03 EDT
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

I tried to recompile the original redhat kernel with the original
sources on the RS_WS3 PC. The problem is, that the kernel compilation
I do the compilation via the following steps:

1. I solved the original .config file into a temporary directory
2. I changed to /usr/src/linux-2.4.21-4.EL/
3. I do a "make disclean + mrproper" to clean up the sources
4. I copied the file configs/kernel-2.4.21-i686.config to .config
5. "make xconfig" and after that I exit the gui immediately. This was
only to provide the foundations for the next step
6. "make dep", "make clean" -- no problem until here
7. During a "make bzImage" the compilation aborts. Here ist the output
of the last few lines:

make -C ipv4 modules
make[2]: Entering directory `/usr/src/linux-2.4.21-4.EL/net/ipv4'
gcc -D__KERNEL__ -I/usr/src/linux-2.4.21-4.EL/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing
-fno-common  -Wno-unused         -fomit-frame-pointer -pipe
-freorder-blocks -mpreferred-stack-boundary=2 -march=i686 -DMODULE
-DMODVERSIONS -include                
/usr/src/linux-2.4.21-4.EL/include/linux/modversions.h  -nostdinc
-iwithprefix include -DKBUILD_BASENAME=ipip  -DEXPORT_SYMTAB -c ipip.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.21-4.EL/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing
-fno-common  -Wno-unused -fomit-frame-pointer -pipe -freorder-blocks
-mpreferred-stack-boundary=2 -march=i686 -DMODULE -DMODVERSIONS
-include /usr/src/linux-2.4.21-4.EL/include/linux/modversions.h 
-nostdinc -iwithprefix include -DKBUILD_BASENAME=ip_gre 
-DEXPORT_SYMTAB -c ip_gre.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.21-4.EL/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing
-fno-common  -Wno-unused -fomit-frame-pointer -pipe -freorder-blocks
-mpreferred-stack-boundary=2 -march=i686 -DMODULE -DMODVERSIONS
-include /usr/src/linux-2.4.21-4.EL/include/linux/modversions.h 
-nostdinc -iwithprefix include -DKBUILD_BASENAME=ah4  -c -o ah4.o ah4.c
In file included from ah4.c:6:
/usr/src/linux-2.4.21-4.EL/include/net/ah.h: In function `ah_hmac_digest':
/usr/src/linux-2.4.21-4.EL/include/net/ah.h:26: warning: implicit
declaration of function `crypto_hmac_init_R5c1407c5'
`crypto_hmac_update_R22d33acd' undeclared (first use in this function)
/usr/src/linux-2.4.21-4.EL/include/net/ah.h:27: (Each undeclared
identifier is reported only once
/usr/src/linux-2.4.21-4.EL/include/net/ah.h:27: for each function it
appears in.)
/usr/src/linux-2.4.21-4.EL/include/net/ah.h:28: warning: implicit
declaration of function `crypto_hmac_final_R3c03b770'
make[2]: *** [ah4.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.4.21-4.EL/net/ipv4'
make[1]: *** [_modsubdir_ipv4] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.21-4.EL/net'
make: *** [_mod_net] Error 2

I thinked, that the problem cames from a disabled cryptographic
algorithm within the .config file. So I cleaned up the kernel sources
and try to enable it using the "make xconfig" - step. But if I choose
"cryptograhic options" within the configuration gui, all entries are

If I use the .config - file within a fresh kernel source package
(www.kernel.org), this is not the case. So how is it possible to
recompile the kernel ?
I want to try out, if we have the same problems as described in my
last email, using a recompiled kernel with complete original Redhat Kernel
Comment 2 Rik van Riel 2004-07-02 09:27:29 EDT
Instead of make xconfig, you should run 'make oldconfig' twice. 

The config files shipped by Red Hat are auto-generated with some
scripts and some config items depend on things earlier in the
configuration sequence, which is the reason you need to run 'make
oldconfig' twice.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.