Bug 127124 - Remove explicit kernel-dependency
Summary: Remove explicit kernel-dependency
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-02 10:50 UTC by Enrico Scholz
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 17:47:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2004-07-02 10:50:56 UTC
Description of problem:

It would be nice when the

| Requires: kernel >= 2.4

dependency would be removed or be rewritten to

| Conflicts: kernel < 2.4


The first statement has its origin in ancient distributions (before
RH7.0??) and is fulfilled by nearly every modern installation.
Requirements on a recent installation are brought in by the
BuildRequires: also.

But such an explicit 'Requires:' introduces unneeded dependencies (the
kernel-package and its deptree) in chroot-environments like Linux
VServers.



Version-Release number of selected component (if applicable):

bind-9.2.3-16.1

Comment 1 Barry K. Nathan 2004-07-14 09:54:07 UTC
Unfortunately, "Requires: kernel >= 2.4" and "Conflicts: kernel < 2.4"
say two different things. On a system with both 2.2 and 2.4 kernel
packages installed, the first requirement is satisfied but the second
is not...

Comment 2 Enrico Scholz 2004-07-14 09:58:52 UTC
Then, remove it completly. afaik, every supported RH distribution has
kernels above 2.4.0

Comment 3 Jason Vas Dias 2004-07-28 17:47:53 UTC
'Requires: kernel >= 2.4' 
will be removed from next bind version (bind-9.2.4rc6-4)
.



Note You need to log in before you can comment on or make changes to this bug.