Description of problem:
It would be nice when the
| Requires: kernel >= 2.4
dependency would be removed or be rewritten to
| Conflicts: kernel < 2.4
The first statement has its origin in ancient distributions (before
RH7.0??) and is fulfilled by nearly every modern installation.
Requirements on a recent installation are brought in by the
But such an explicit 'Requires:' introduces unneeded dependencies (the
kernel-package and its deptree) in chroot-environments like Linux
Version-Release number of selected component (if applicable):
Unfortunately, "Requires: kernel >= 2.4" and "Conflicts: kernel < 2.4"
say two different things. On a system with both 2.2 and 2.4 kernel
packages installed, the first requirement is satisfied but the second
Then, remove it completly. afaik, every supported RH distribution has
kernels above 2.4.0
'Requires: kernel >= 2.4'
will be removed from next bind version (bind-9.2.4rc6-4)