Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1271268 - JobExecutor: sorting order according Id is ignored when different filters are selected
Summary: JobExecutor: sorting order according Id is ignored when different filters are...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.2.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Neus Miras
QA Contact: Pavel Kralik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-13 13:53 UTC by Pavel Kralik
Modified: 2015-11-24 10:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-24 10:19:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Pavel Kralik 2015-10-13 13:53:08 UTC
Description of problem:
When sorting descending order according Id in the Queued tab is selected and then switched to the All tab, sorting order is lost. 

Version-Release number of selected component (if applicable):
BPMS 6.2.0.ER3

How reproducible:
Always

Steps to Reproduce:
1. Go to the Queued tab and select Id descending order.
2. Swicth to the All tab and see ascending Id order.


Actual results:
Sorting order differs filter to filter.

Expected results:
Sorting order should be the same in different tabs.

Additional info:

Comment 2 Kris Verlaenen 2015-10-13 15:30:47 UTC
Tbh, I would expect / prefer the sorting order to be independent in each tab.  While you might sort on one column in one direction on one filter, you could do something completely different on another one.

In some advanced filters (in process instance list for example) you even might end up with different columns being available in different filters, so not sure a strategy where you try to sort the same on different filter is even possible there?

Comment 3 Pavel Kralik 2015-11-24 10:19:26 UTC
Previous versions eg. 6.1 have this behaviour. Since 6.2 it is a feature. Closing bug.


Note You need to log in before you can comment on or make changes to this bug.