Bug 127128 - Fedora Core 2 x86_64 fails to install
Fedora Core 2 x86_64 fails to install
Status: CLOSED DUPLICATE of bug 119447
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-02 08:39 EDT by Henrik J. Haar
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dumpfile from installation (689.35 KB, text/plain)
2004-07-02 08:41 EDT, Henrik J. Haar
no flags Details

  None (edit)
Description Henrik J. Haar 2004-07-02 08:39:10 EDT
Description of problem:
Fedora Core 2 x86_64 fails to install.
Installing from DVD image

Hardware:
Chaintech motherboard ZNF3-250
AMD 64 XP 3200+
Maxtor ATA133 harddisk 200GB

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Henrik J. Haar 2004-07-02 08:41:17 EDT
Created attachment 101595 [details]
Dumpfile from installation
Comment 2 Jeremy Katz 2004-07-06 18:19:30 EDT
Is this a kickstart install?  Does it happen every time you try to
install?
Comment 3 Henrik J. Haar 2004-07-06 21:03:13 EDT
Yes, it happens every time!
Exactly the same error every time.
I boot from the DVD-ROM and every thing goes fine, until the point 
where the installation is going to copy the selected portion of 
packages to the harddrive.

I have tried a minimal installation, an installation without 
recognition of hardware, different graphics adapters, with and 
without my raid controller (Adaptec 2410 SATA with 4 x 200GB Maxtor 
harddrives), different DVD-ROM drives and even disabled my USB 
controller in BIOS, automatic and manual partitioning of the harddrive
(s), 'and yes, I have remembered to format the harddrive(s) every 
time'...

To check the hardware, I have run a burn in test and also tried to 
install Windows XP including all drivers, without any errors...
Comment 4 Pete Stieber 2004-07-09 14:12:26 EDT
This might not be the exact same problem, but see bug number 124029. 
The work around for me was to use

linux mem=256M

when installing. My HW

MB: Tyan Tomcat K8S(S2850G2N)
Processor: AMD Opteron 146 (2GHz)
RAM: 1 GB
HD: Maxtor 80GB 7200 RPM IDE ULTRA ATA 133

Maybe it's a problem with x86_64 systems with more that X MB of 
memory where X > 256M.
Comment 5 Henrik J. Haar 2004-07-09 18:52:23 EDT
I have now been working with the problem for a couple of days and 
have found the problem!
The 2Gigs of memory isn't the problem, but the main harddisk!
The harddisk I'm installing to is a Maxtor ATA 133 200GB!
I have for now tried two identical harddisks, there are nothing wrong 
with them when I try other OS.
Instead I tried a Maxtor ATA 133 120GB harddisk and after forcing it 
to LBA in BIOS instead of AUTO, everything works fine!
I have now tried everything (I think!?) but can't make my 200GB 
harddisk work with FC2 X86_64, the installation crashes everytime.
My Adaptec 2410 SATA RAID with 4 x 200GB harddisks works fine and is 
automatic recognized during installation, but I had to do the "fdisk" 
and "mkfs" manually, because the installation only left me 186MB free 
on the RAID!
I have tried the 200GB harddisk on FC2 I386 version with a standard 
motherboard and a 32bit Athlon XP 2600+ and here everything works 
fine!

Thanks to both of You for suggestions to my problem!!!
And a BIG thank You to all the developers around the world, for the 
best OS ever!!!
I am now looking forward to enjoy using my new 64bit FC2 X86_64 
server...

Henrik
Comment 6 Henrik J. Haar 2004-07-15 17:28:46 EDT
I have found out a bit more about my installation problem!
I also tried a 200GB Maxtor SATA harddrive and got the same problem.
But if I make the partitions smaller, the problem disapears!
I use ext3 for my partitions.
If I partition my 200GB with 300MB for boot, 1500MB for swap and the
last amount for root "/", the installation crashes!
But if I use 300MB for boot, 1500MB for swap, 100000MB for "/usr" and
the last for root"/", then everything works fine!
Does anybody know about a limit in the size of the ext3 partitions
using FC2 x86_64?
The problem doesn't exist using FC2!

Henrik
Comment 7 Jeremy Katz 2004-10-07 14:54:36 EDT

*** This bug has been marked as a duplicate of 119447 ***
Comment 8 Red Hat Bugzilla 2006-02-21 14:04:19 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.