Bug 1271328 - Ability to define ImageStreams for external registries that require authentication
Ability to define ImageStreams for external registries that require authentic...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.0.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michal Minar
weiwei jiang
:
Depends On:
Blocks: 1267746
  Show dependency treegraph
 
Reported: 2015-10-13 12:16 EDT by Josep 'Pep' Turro Mauri
Modified: 2017-03-08 13 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1337330 (view as bug list)
Environment:
Last Closed: 2016-09-27 05:30:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josep 'Pep' Turro Mauri 2015-10-13 12:16:42 EDT
Some environments need to access images that are stored in registries that require authentication.

Right now (OSE 3.0) ImageStreams do not work in that scenario.

I believe it's possible to define pod specs pointing directly at the needed images (i.e. not use an ImageStream) and provide pull secrets so they can be downloaded, this misses the benefits of ImageStreams.

This is a request to be able to define ImageStreams that access external registries that require authentication.
Comment 8 errata-xmlrpc 2016-09-27 05:30:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933

Note You need to log in before you can comment on or make changes to this bug.