Bug 127133 - w5c7q4: tar -f's mandatory argument can be deferred. go figure.
Summary: w5c7q4: tar -f's mandatory argument can be deferred. go figure.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Academy
Classification: Retired
Component: RHA030 Curriculum (Show other bugs)
(Show other bugs)
Version: 2.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bowe Strickland
QA Contact: Bowe Strickland
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-02 13:35 UTC by Bowe Strickland
Modified: 2007-04-18 17:09 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-07 17:29:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bowe Strickland 2004-07-02 13:35:59 UTC
Workbook 5: The Linux Filesystem
> Chapter 7. Archiving Files with tar
> Questions
> 
> 4.  You have downloaded a file titled linux-2.5.34.tar.gz.
> Which of the following commands can you run to extract the
> contents of the file?
> 
> Y  A. tar xvzf linux-2.5.34.tar.gz
>     B. tar -x -f linux-2.5.34.tar.gz
> Y  C. tar -x -z -f linux-2.5.34.tar.gz
>     D. tar -xZf linux-2.5.34.tar.gz
> N  E. tar xfz linux-2.5.34.tar.gz
> Y  F. tar -x -f linux-2.5.34.tar.gz -z
> 
> "E" is actually a correct answer.
>                     (Linux version 2.4.20-8)
> 
i'll be danged... it shouldn't be, because -f takes a required argument
(the name of the archive), but apparently its treated as a special case 
by tar.  noted.  Thanx!


Note You need to log in before you can comment on or make changes to this bug.