Bug 1271331 - '-c' option of sandbox does not work.
'-c' option of sandbox does not work.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: policycoreutils (Show other bugs)
7.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Petr Lautrbach
Dalibor Pospíšil
:
Depends On:
Blocks: 1364088
  Show dependency treegraph
 
Reported: 2015-10-13 12:24 EDT by Dalibor Pospíšil
Modified: 2016-11-03 22:13 EDT (History)
7 users (show)

See Also:
Fixed In Version: policycoreutils-2.5-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1091139
Environment:
Last Closed: 2016-11-03 22:13:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Remove -c option from man page (2.77 KB, text/plain)
2016-05-10 03:22 EDT, Petr Lautrbach
no flags Details

  None (edit)
Description Dalibor Pospíšil 2015-10-13 12:24:55 EDT
+++ This bug was initially created as a clone of Bug #1091139 +++

Customer Contact Name:
  Yasuyuki Kobayashi
  
Description of Problem:
  The man page of sandbox command shows as below:
  ------------------
  -c  Use control groups to control this copy of sandbox. Specify parameters
      in /etc/sysconfig/sandbox. Max memory usage and cpu usage are to be
      specified in percent. You can specify which CPUs to use by numbering them
      0,1,2... etc.
  ------------------
  
  And we set the file /etc/sysconfig/sandbox as following:
  -----------------
    # Space separate list of homedirs
    HOMEDIRS="/home"
    # Control group configuration
    NAME=sandbox
    CPUAFFINITY=ALL
    MEMUSAGE=80%
    CPUUSAGE=80%
  ----------------

  We think that if cgroup has been used to control sandbox,
  there should be directory "/cgroup/memory/sandbox" and "/cgroup/cpu/sandbox" in the directory "/cgroup".
  But, there is no such directory in "/cgroup" after executing "sandbox -c id -Z".
  ---------------
  # sandbox -c id -Z
  unconfined_u:unconfined_r:sandbox_t:s0:c580,c885
  # ls /cgroup/cpu/sandbox
  ls: cannot access /cgroup/cpu/sandbox: No such file or directory 
  ---------------
  So please fix sandbox to use cgroup correctly when specified '-c' option.
  
  Version-Release number of selected component:
  policycoreutils-2.2.5-15.el7

  How reproducible:
  Always 
  
  Step to Reproduce:
  1. see linked test
Comment 1 Daniel Walsh 2015-10-13 18:26:35 EDT
-c should be dropped.
Comment 2 Petr Lautrbach 2016-05-10 03:22 EDT
Created attachment 1155581 [details]
Remove -c option from man page
Comment 6 errata-xmlrpc 2016-11-03 22:13:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2279.html

Note You need to log in before you can comment on or make changes to this bug.