Bug 1271342 - JVM running Eclipse crashes several times per day
JVM running Eclipse crashes several times per day
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: eclipse (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: alpha
: 4.1
Assigned To: Mat Booth
Václav Kadlčík
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 13:07 EDT by Levente Farkas
Modified: 2016-05-31 04:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: devtoolset-4-eclipse-4.5.1-7.1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-31 04:41:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2015-10-13 13:07:34 EDT
the latest devtoolset-3 eclipse crash many times a day because of these bugs:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=427776
https://git.eclipse.org/r/#/c/43156/
http://git.eclipse.org/c/platform/eclipse.platform.swt.git/commit/?id=e9c202445b7800e816318f00aed3887885c67efd

so it'd be useful to update devtoolset-3-eclipse or gtk3 (or both) in rhel-7.

ps. we use the latest release:
devtoolset-3-eclipse-platform-4.4.2-4.el7.centos.x86_64
Comment 1 Mat Booth 2016-01-21 10:29:40 EST
I believe this will be fixed in DTS 4.1, certainly the patch cited above is present in Mars.1
Comment 2 Levente Farkas 2016-01-21 10:34:18 EST
any estimate for DTS 4.1? since currently even devtoolset-4's eclipse package still not released:-(
anyway i'd be hapy to test these rpms too:-)
Comment 3 mbenitez 2016-01-21 10:44:54 EST
(In reply to Levente Farkas from comment #2)
> any estimate for DTS 4.1? since currently even devtoolset-4's eclipse
> package still not released:-(
> anyway i'd be hapy to test these rpms too:-)

DTS releases approximately every 6 months. DTS 4.1 is expected some time in the Spring. Unfortunately we can not comment on any more specific dates.
Comment 4 Mat Booth 2016-01-21 11:22:59 EST
(In reply to Levente Farkas from comment #2)
> any estimate for DTS 4.1? since currently even devtoolset-4's eclipse
> package still not released:-(
> anyway i'd be hapy to test these rpms too:-)

Hmm, DTS 4.0 should be available: http://developerblog.redhat.com/2015/11/17/gcc-5-developer-toolset-4-generally-available/
Comment 8 Václav Kadlčík 2016-03-08 06:04:58 EST
verified in the second DTS 4.1 alpha hand-off
Comment 10 errata-xmlrpc 2016-05-31 04:41:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1145

Note You need to log in before you can comment on or make changes to this bug.